#3030 Separation of IPA specific variables and framework in Web UI
Closed: wontfix 5 years ago Opened 11 years ago by pvoborni.

Currently the 'IPA' object is both used as a singleton/global variable and also as a name space for the framework.

We should use a generic/non-IPA specific name for the framework. Probably something like this:

  // UI Framework
  var UI = { ... };
  UI.entity = function() { ... };
  UI.facet = function() { ... };

  // IPA UI
  var IPA = UI();
  IPA.user.entity = function() { ... };
  IPA.user.details_facet = function() { ... };

  IPA.init();

source: email with Endi


Metadata Update from @pvoborni:
- Issue assigned to pvoborni
- Issue set to the milestone: Future Releases

7 years ago

Thank you taking time to submit this request for FreeIPA. Unfortunately this bug was not given priority and the team lacks the capacity to work on it at this time.

Given that we are unable to fulfil this request I am closing the issue as wontfix. To request re-consideration of this decision please reopen this issue and provide additional technical details about its importance to you.

Metadata Update from @rcritten:
- Issue close_status updated to: wontfix
- Issue status updated to: Closed (was: Open)

5 years ago

Login to comment on this ticket.

Metadata