#1856 [ipa webui] In adder_dialog, no error indicated when choosing to enroll without selecting an object
Closed: Fixed None Opened 10 years ago by rcritten.

https://bugzilla.redhat.com/show_bug.cgi?id=740885

Description of problem:
For an HBAC rule, you can choose to add a Host in "Accessing" section. Click on 'Enroll' without selecting any host, and no error is thrown to indicate that a host was not selected to be enrolled.

Same behaviour seen in other areas where adder dialog used.

Version-Release number of selected component (if applicable):
ipa-server-2.1.1-4.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1. Add and edit HBAC rule
2. Go to its Accessing section, and click to Add a Host
3. Click 'Enroll' without selecting a host

Actual results:
you are brought back to the HBAC rule settings page

Expected results:
An error to indicate that no host was selected to be enrolled

Additional info:

Currently the server doesn't return an error when adding an empty set of members. This behavior is consistent with CLI:

# ipa hbacrule-add-host testhbacrule --hosts=
  Rule name: testhbacrule
  Enabled: TRUE
  User Groups: editors, ipausers
  Source Hosts: test.example.com
-------------------------
Number of members added 0
-------------------------

Error is that the button should not be enabled if there is nothing to enroll.

Metadata Update from @rcritten:
- Issue assigned to edewata
- Issue set to the milestone: FreeIPA 2.1.2 (bug fixing)

5 years ago

Login to comment on this ticket.

Metadata