c0461eb spec: require pki-acme if pki-ca >= 10.10

1 file Authored by ftweedal 2 years ago, Committed by rcritten 2 years ago,
    spec: require pki-acme if pki-ca >= 10.10
    
    We can use conditional dependencies (described at [1]) to require
    the pki-acme package if pki-ca >= 10.10.0 (the version at which the
    ACME service was separated to a subpackage).
    
    [1] https://rpm.org/user_doc/boolean_dependencies.html
    
    I have tested this with repos having only pki-10.9.x (and therefore
    no pki-acme package), and dnf is happy.  I have also testing package
    installation with pki-10.10 packages installed, but /without/
    pki-acme installed. pki-acme was seen as a missing dependency and
    installed alongside the freeipa packages.  This change seems to
    satisfy all the scenarios.
    
    Related: https://github.com/dogtagpki/pki/pull/513
    Reviewed-By: Florence Blanc-Renaud <frenaud@redhat.com>
    
        
file modified
+2 -0