44b3791 Require idstart to be larger than UID_MAX

Authored and Committed by cheimes 2 months ago
    Require idstart to be larger than UID_MAX
    
    ipa-server-install fails if idstart is set to 0. There might be
    additional issues when idstart overlaps with local users. Ensure that
    idstart is larger than UID_MAX or GID_MAX from /etc/login.defs.
    
    Fixes: https://pagure.io/freeipa/issue/8137
    Signed-off-by: Christian Heimes <cheimes@redhat.com>
    Reviewed-By: Alexander Bokovoy <abokovoy@redhat.com>