43a9708 Update Azure Pipelines to use Fedora 31

Authored and Committed by abbra 2 years ago
    Update Azure Pipelines to use Fedora 31
    
    nodejs:12 requires libicu-65.1 while gdb (not direct dependency)
    libicu-63.2. As a workaround gdb-minimal [0] could be used.
    It's even better as requires less packages to be downloaded
    and then installed.
    
    [0] https://fedoraproject.org/wiki/Changes/Minimal_GDB_in_buildroot
    
    Co-authored-by: Stanislav Levin <slev@altlinux.org>
    Signed-off-by: Stanislav Levin <slev@altlinux.org>
    Reviewed-By: Christian Heimes <cheimes@redhat.com>