0d6caf5 Remove test for minimum ACME support and rely on package deps

Authored and Committed by rcritten a year ago
    Remove test for minimum ACME support and rely on package deps
    
    This method was added temporarily while the required packages
    were still under development and not available in stable
    repositories.
    
    Signed-off-by: Rob Crittenden <rcritten@redhat.com>
    Reviewed-By: Alexander Bokovoy <abokovoy@redhat.com>