#2680 F36 Change: Enforce Authselect Configuration Consistency
Closed: Accepted 2 months ago by zbyszek. Opened 3 months ago by bcotton.

This change wants to make authselect required to configure authentication and identity sources and forcefully update non-authselect configuration to the sssd authselect profile to eliminate any existing non-authselect setups.

Even though it will still be possible to manually modify the configuration, users that require special configuration should create and use custom authselect profile.

Authselect is available in Fedora since Fedora 27 and enabled by default on new installations since Fedora 28. Authconfig compatibility tool was removed from Fedora 35 as a system wide change. It is now well accepted by the community as well as the package maintainers. The package maintainers have repeatedly requested to make authselect mandatory for the users which lead to creation of this bugzilla.


After a week, the vote is (+1,0,-0). Waiting for additional votes.

Processing this approval as

APPROVED (+2,0,-0)

Metadata Update from @bcotton:
- Issue tagged with: pending announcement

2 months ago

Metadata Update from @zbyszek:
- Issue untagged with: pending announcement
- Issue close_status updated to: Accepted
- Issue status updated to: Closed (was: Open)

2 months ago

Login to comment on this ticket.

Metadata