#2626 F35 Change: Remove authselect-compat package
Closed: Accepted 3 months ago by zbyszek. Opened 4 months ago by bcotton.

Authselect replaced authconfig tool in Fedora 28. To enable some level of backwards compatibility, it ships the authconfig command as a wrapper around authselect calls in package "authselect-compat". Authselect is now well adopted and the shim compatibility layer should be removed by removing the authselect-compat package.


Wouldn't this break anything using authconfig command in kickstart (anything building with lorax or appliance-tools/livecd-tools, or installing with anaconda?)?

@ngompa authconfig will no longer be available in kickstart, it needs to be switched to authselect. If you are aware of more components that still use authconfig, please name them in the change page or here and I will communicate the change, if accepted.

Keeping compat for 5 Fedora releases is more than enough.

+1

@ngompa authconfig will no longer be available in kickstart, it needs to be switched to authselect. If you are aware of more components that still use authconfig, please name them in the change page or here and I will communicate the change, if accepted.

Lorax and appliance-tools still have authconfig and the latter has no implementation of authselect yet.

Lorax and appliance-tools still have authconfig and the latter has no implementation of authselect yet.

At this point in time, this is OK. F35 code-complete deadline is 2021-08-24, so there should be enough time to patch various projects.

After a week, I count the vote as (+4,0,-0). Processing the proposal as approved.

Metadata Update from @bcotton:
- Issue tagged with: pending announcement

3 months ago

Metadata Update from @zbyszek:
- Issue untagged with: pending announcement
- Issue close_status updated to: Accepted
- Issue status updated to: Closed (was: Open)

3 months ago

Login to comment on this ticket.

Metadata