#2308 F32 System-Wide Change: Ruby 2.7
Closed: Accepted 7 months ago by psabata. Opened 7 months ago by bcotton.

Ruby 2.7 is the latest stable version of Ruby. Many new features and improvements are included for the increasingly diverse and expanding demands for Ruby. With this major update from Ruby 2.6 in Fedora 31 to Ruby 2.7 in Fedora 32, Fedora becomes the superior Ruby development platform.


I remember reading that Ruby 2.7 will need a bootstrap build, since Ruby 2.7 cannot be built with Ruby 2.6, but the Change proposal does not mention it. So either I am wrong or it's missing from the proposal. :disappointed:

Assuming the need for the bootstrap build can be sorted out, I am entirely ok with a system-wide change to Ruby 2.7.

+1

Just to be clear, I'd vote +1 here.

I also found the ML post about the boostrap problem, and would like to know if this already affects ruby 2.7.0.

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/LH6L6YJOYQT4Y5ZNOO4SLIPTUWZ5V45Q/

+1, which gives this +7 in total.

Metadata Update from @psabata:
- Issue tagged with: pending announcement

7 months ago

Metadata Update from @psabata:
- Issue untagged with: pending announcement
- Issue close_status updated to: Accepted
- Issue status updated to: Closed (was: Open)

7 months ago

Login to comment on this ticket.

Metadata