#2250 General Python 2 exception for packages that only BR the interpreter
Closed: Accepted 23 days ago by ignatenkobrain. Opened a month ago by churchyard.

We would like to request a general exception for packages that only BR Python 2 to be able to continue doing it in Fedora 32 (but no further).

Proposal: Any package that BuildRequires Python 2, but has no other dependencies that require Python 2, even transitively, either at build time or run time is allowed to continue to BuildRequire Python 2 in Fedora 32. This exception is not valid for Fedora 33+ (if not agreed upon explicitly).

There are around 100 of these, from "0ad" through "firefox" to "zziplib".

Clarification: BuildRequires: python2-devel is considered as "only BRing the interpreter".

We would like to postpone dealing with these to Fedora 33.


Just to clarify, will python2-devel finally stop depending on python2-setuptools? If so, I'm definitely +1. If not, I would suggest doing so and give +1.

Yeah, that seems reasonable. We would approve each of them anyway, so there is no point in going one-by-one and wasting everyone's time.

+1

Just to clarify, will python2-devel finally stop depending on python2-setuptools?

There is no python2-devel any more, it is just provided by python27. python27 doesn't depend on python2-setuptools.

Just to clarify, will python2-devel finally stop depending on python2-setuptools?

There is no python2-devel any more, it is just provided by python27. python27 doesn't depend on python2-setuptools.

:thumbsup:

+1 makes it APPROVED (+6,0,-0)

Metadata Update from @churchyard:
- Issue tagged with: pending announcement

a month ago

Metadata Update from @ignatenkobrain:
- Issue close_status updated to: Accepted
- Issue status updated to: Closed (was: Open)

23 days ago

Login to comment on this ticket.

Metadata