#2183 F31 Self-Contained Change: Bundler 2.0
Closed: Accepted 4 days ago by zbyszek. Opened a month ago by bcotton.

Upgrade to Bundler 2.0, the latest stable gem version.


+1, this is backwards-compatible change to some extent. Projects which have lock file in 1.x format will continue work (thanks to compat package).

After 7 days, I count the vote as (+4,0,-0). By policy, I am processing this Change as approved.

Metadata Update from @bcotton:
- Issue tagged with: pending announcement

22 days ago

Sorry for late post, I've unfortunatelly missed this thread.

+1, this is backwards-compatible change to some extent. Projects which have lock file in 1.x format will continue work (thanks to compat package).

To clarify a bit:

There's actually no plan to create a standalone -compat package. Ruby now ships with Bundler (Version 1.17.2 currently), which we provide as a subpackage (currently rubygem-bundler; after the change rubygem-bundler1).

When new Ruby (with Bundler 2.X) is released, then we'll rename the subpackage back to rubygem-bundler and there'll be no rubygem-bundler1.

On the plus-side, all Gemfiles working with Bundler 1.X will continue to work with Bundler 2.X (bundle update --bundler is needed), as the maintainers (currently) guarantee forward-compatibility.

Metadata Update from @zbyszek:
- Issue close_status updated to: Accepted
- Issue status updated to: Closed (was: Open)

4 days ago

Metadata Update from @zbyszek:
- Issue untagged with: pending announcement

4 days ago

Login to comment on this ticket.

Metadata