#64 Enable 3rd party repositories step missing from initial setup
Closed: Deferred to upstream a month ago by catanzaro. Opened a year ago by aday.

Somehow we lost this. It would be good to add it back, in order to both advertise the feature and to allow users to enable it from the start.

Upstream issue - https://gitlab.gnome.org/GNOME/gnome-initial-setup/issues/3


Note that the GNOME Software developers removed this functionality from GNOME Software, without updating gnome-initial-setup, so this is an upstream issue.

Note that the GNOME Software developers removed this functionality from GNOME Software, without updating gnome-initial-setup, so this is an upstream issue.

Sorry, I don't know what this means.

This gnome-initial-setup page exists to toggle a boolean gsetting, org.gnome.software show-nonfree-software. That setting was removed in GNOME 3.28. Therefore, the only thing the page could do if it were to be displayed would be to crash when trying to access the nonexistent gsetting.

It's not really a regression, because this page has never been visible in Fedora (unless you deliberately skipped user account creation in Anaconda, which users would never do).

Anyway, of course it would be good to fix. Perhaps @kalev might want to look into it.

So I'm not sure there's much for Workstation WG to track here. If we want to bring back this page, we need either @rhughes or @kalev to devote time to the issue. Otherwise it's just gone.

Metadata Update from @catanzaro:
- Issue close_status updated to: Deferred to upstream
- Issue status updated to: Closed (was: Open)

a month ago

Login to comment on this ticket.

Metadata