#153 image links fail to load
Closed: Fixed None Opened 5 years ago by mattdm.

Take a look at http://fedoramagazine.org/?p=1236 and click on one of the slides. Each of these is supposed to be an external link, but instead, some sort of javascript photo viewer popup happens, with "This content failed to load."

If you right click and say "open in new window", that works just fine.


In my blog I am running the same wordpress version with the magazine, and I did a quick test, setting an image I had in a post with your url (http://mattdm.org/fedora/next2014/#3), and it redirected me with no problem. In the magazine, in another post, I tried to link a different url (google.com) with another image, and it didn't redirect me, it showed me the same error "This content failed to load". So technically we can't a link a url with an image in any post in the magazine :(

Also in my blog there was no 'pop up', it just redirected me at once. So there seems to be a bug with the theme. I'm ccing Ryan Lerch, who build the child theme we are using right now, if there is something he could do.

The error is due to CORS (Cross Origin Resource Sharing), being disabled. The error shows up on the js console when you attempt to load the image into the lightbox:
{{{
Cross-Origin Request Blocked: The Same Origin Policy disallows reading...
}}}

Correct this by adding the following clip to fedoramagazine.org/.htaccess:
{{{
Header set Access-Control-Allow-Origin "*"
}}}

Hiya!

Would someone know the status of this ticket? Has the issue been fixed? Should I close it?

Login to comment on this ticket.

Metadata