#180 Update to wayland to 1.20 or later
Opened 5 months ago by ngraham. Modified 4 months ago

KDE's kwayland-server package was updated to require https://invent.kde.org/plasma/kwayland-server/-/commit/7ed6fae8e2638ad2896d3d3e957a09ddd16ded21 today, and this will go into Plasma 5.25.

Fedora currently ships Wayland 1.19, which is a year old. The current release is 1.25 1.20. See https://wayland.freedesktop.org/releases.html

We will need to update the version before we ship Plasma 5.25, and even sooner would be better, as right now KDE people will need to compile Wayland themselves to be able to build KWin from source.


@ngraham don't you mean latest release is 1.20?

Rawhide and F36 both have 1.20 already

Am I confusing here wayland-protocols and wayland?

They are different packages, yes.

However I'm on F35, not rawhide or 36.

@ngraham : https://src.fedoraproject.org/rpms/wayland-protocols <--- 1.25

https://src.fedoraproject.org/rpms/wayland <--- 1.19.0 for F35.

Just to be clear: we will need 1.20.0 of wayland (package name) if we wanna upgrade to plasma 5.25.0, right?

That is correct.

Those two package versions should probably be kept in sync, too.

Metadata Update from @ngompa:
- Issue assigned to ngompa

5 months ago

Nice, thanks!

Is there a way in the future to ensure or hint that those two packages have their versions kept in sync? Or would this always be a manual process?

They can't be kept in sync since they don't synchronously release.

Looks like wayland and wayland-protocols need to be updated in EL8 and EL9 for Plasma 5.25, so I've filed bugs for both:

EL9:

EL8:

Metadata Update from @ngompa:
- Issue tagged with: epel, need-work

5 months ago

Metadata Update from @ngompa:
- Issue set to the milestone: Plasma 5.25

5 months ago

Upgrade for wayland has been rejected for EL8, on the basis that it causes a severe crash with no fix in mutter right now and for this phase for RHEL 8, upgrading it doesn't make sense. Nothing has happened for EL9 yet, but I'm not optimistic right now.

Metadata Update from @siosm:
- Issue tagged with: packaging

4 months ago

Metadata Update from @siosm:
- Issue untagged with: packaging
- Issue tagged with: updates

4 months ago

Login to comment on this ticket.

Metadata
Boards 1
Updates Status: Blocked