#111 Update wayland-protocols-devel to 1.22
Closed: Fixed 6 months ago by ngompa. Opened 11 months ago by ngraham.

The dependency version for wayland-protocols in plasma-wayland-protocols was just increased upstream from 1.21 to 1.22 in https://invent.kde.org/plasma/kwayland-server/-/commit/7354d8de40d24929290d2f7dc8b4f2d77a5b97ce to support DRM leasing.

wayland-protocols 1.22 will therefore be required for Plasma 5.24. It was released 19 days ago: https://github.com/wayland-project/wayland-protocols/releases/tag/1.22

It would be nice to get it in earlier rather than later so that devs who build from source can use distro packages rather than building this from source as well.


Metadata Update from @ngompa:
- Issue assigned to ngompa

11 months ago

I'll need to make requests for this for CentOS Stream 8 and CentOS Stream 9. Especially since Plasma 5.24 is likely to be the first version for RHEL 9.

Updates have been proposed to upgrade to wayland-protocols-1.23 in Fedora:

I've submitted a merge request for CentOS Stream 9 (gl#redhat/centos-stream/rpms/wayland-protocols!3) and supplied a patch for CentOS Stream 8 in the relevant BZ.

Metadata Update from @ngompa:
- Issue set to the milestone: Red Hat Enterprise Linux 8.6

10 months ago

Metadata Update from @ngompa:
- Issue set to the milestone: Plasma 5.23 (was: Red Hat Enterprise Linux 8.6)

10 months ago

Metadata Update from @ngompa:
- Issue set to the milestone: Plasma 5.24 (was: Plasma 5.23)

10 months ago

This was completed a while ago. @ngraham, please file a new issue if we need a new wayland-protocols upgrade in Fedora and/or CentOS/RHEL.

Metadata Update from @ngompa:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

6 months ago

Login to comment on this ticket.

Metadata