#9865 Cannot look at threads in Taiga board
Opened a month ago by theevilskeleton. Modified 10 days ago

Describe what you would like us to do:


Hi,

This is a copy/paste from https://discussion.fedoraproject.org/t/bug-cannot-look-at-threads-in-taiga-board/28800?u=theevilskeleton:

When I try to look at a thread (like this this one), it gives me a blank page[1].

It’s not working on my laptop, desktop and phone. Everything used to work on my laptop a week ago but the threads randomly stopped working on my side. It’s hard for me to work on the article I am writing, and I don’t want to keep nagging someone to update it.

I tried changing DNS servers, I tried it in Chrome and another Firefox profile, but I had no luck.

I don’t know how to retrieve the logs, so if anybody is willing to help me on that, I would appreciate it.

[1] https://aws1.discourse-cdn.com/business4/uploads/fedoraproject/original/2X/3/31121c72c9fdd528340953638f75ae6089cb0c7c.png

When do you need this to be done by? (YYYY/MM/DD)


As soon as possible.

/cc @asamalik


Metadata Update from @mohanboddu:
- Issue priority set to: Waiting on Assignee (was: Needs Review)
- Issue tagged with: low-gain, low-trouble, ops

a month ago

Can you retry again now? There were updates/bugfixes applied this morning...

Unfortunately it still does not work.

Hi there!

Could you share a screenshot with the developer tools open? Both the console and the network tab if possible, please. @theevilskeleton

Regards!

...I think it's worse now. The page is blank.

Screenshot_from_2021-04-20_10-06-49.png

Hi again!

We would need the network tab open during a reload and the console tab, we cannot replicate from our devices.

Regards!

Hmmm, it seems there's no cache, but just in case, could you try a hard reload? (Usually Control+Shift+R). Also, have you tried from different locations? As in, connected to a different source of internet?

Regards!

Yes, I have tried clearing cache, but that does not work.

I didn't connect somewhere else because I'm in the middle of a pandemic, but I have tried Tor, which has no results (FIY I got better results in Tor than on my main system).

Hmmm, it seems there's no cache, but just in case, could you try a hard reload? (Usually Control+Shift+R). Also, have you tried from different locations? As in, connected to a different source of internet?

Regards!

Yes, I have tried clearing cache, but that does not work.

I didn't connect somewhere else because I'm in the middle of a pandemic, but I have tried Tor, which has no results (FIY I got better results in Tor than on my main system).

Sorry for the communication error, I know we're in a pandemic, I meant more in the line of "using mobile data instead of wifi".

Do you replicate this issue when visiting the project anonymously?

Regards!

Unfortunately I don't have alternative ways to get data. I'm stuck with WiFi.

I think this is an OpenID issue. This problem occurs only when I am trying to log in with OpenID.

I tried it in Tor as well. The Kanban board itself works, but as soon as I login, it stops working.

Are you by chance:
entering your email address in the login box
using mixed case for your username if entering username
If so, don't do that. Use username, all lower case.

No. Everything is lower cased and I do not put my email address.

I see that (depending on what Taiga authentication plugin you are using) it might try a complex series of fallbacks when trying to match the name. Excerpted from taiga-contrib-openid-auth:

"... Username fallback The plugin will first try if the OpenID provider contains a feild set in OPENID_USERNAME_FIELD if it does not exist it will try in the following order: preferred_username -> full_name -> username -> email you can override this by changing the intial field to check by setting OPENID_USERNAME_FIELD ..."

I think the account was initially created in mixed case (TheEvilSkeleton) and then renamed to all lower case (theevilskeleton) if that matters.

Correct. My name was initially TheEvilSkeleton. I later renamed it to theevilskeleton.

Correct. My name was initially TheEvilSkeleton. I later renamed it to theevilskeleton.

Hi again, just to discard, it seems you changed your email at some point from a riseup.net domain to a fedoraproject.org domain, did you receive an email to verify the new address?

Regards!

I don't remember if I did, sorry for that. How can I check if the new email is verified?

I don't remember if I did, sorry for that. How can I check if the new email is verified?

You can search for a mail from fedoraproject with "verify email" in the subject, though as the user above mentioned the username should be the key here and mail should not matter much, but let's keep discarding things just in case.

Could you also try changing your language on Taiga? It would be okay changing it to another language, saving, then back to English

I don't remember if I did, sorry for that. How can I check if the new email is verified?

You can search for a mail from fedoraproject with "verify email" in the subject, though as the user above mentioned the username should be the key here and mail should not matter much, but let's keep discarding things just in case.

I regularly delete my emails. Unfortunately, I may have deleted the verification email.

Could you also try changing your language on Taiga? It would be okay changing it to another language, saving, then back to English

Can you guide me? I do not see a settings button. FIY I cannot login at all, so I need to ask someone else to do changes in the Taiga.

I don't remember if I did, sorry for that. How can I check if the new email is verified?

You can search for a mail from fedoraproject with "verify email" in the subject, though as the user above mentioned the username should be the key here and mail should not matter much, but let's keep discarding things just in case.

I regularly delete my emails. Unfortunately, I may have deleted the verification email.

Could you also try changing your language on Taiga? It would be okay changing it to another language, saving, then back to English

Can you guide me? I do not see a settings button. FIY I cannot login at all, so I need to ask someone else to do changes in the Taiga.

Sure, can guide you, but you would need to log in. I thought that part worked? In any case, top right corner there is your profile and you can change your user settings there, including language.

That's the problem. The Taiga instance is really unstable on my side. I'm now logged out and I cannot log in anymore apparently. When I try to log in, OpenID doesn't want to work.

That's the problem. The Taiga instance is really unstable on my side. I'm now logged out and I cannot log in anymore apparently. When I try to log in, OpenID doesn't want to work.

Hmmm, perhaps due to the change in case? Have you tried both with lowercase and capitalized text?

Regards!

That's the problem. The Taiga instance is really unstable on my side. I'm now logged out and I cannot log in anymore apparently. When I try to log in, OpenID doesn't want to work.

Hmmm, perhaps due to the change in case? Have you tried both with lowercase and capitalized text?

Regards!

Yes I have. Both methods did not work.

Login to comment on this ticket.

Metadata
Boards 1
ops Status: Backlog