#9044 User is not receiving emails after Jun 12
Closed: Fixed a month ago by kevin. Opened 2 months ago by vashirov.

Hi,

user @elkris stopped receiving emails after June 12 from mailing lists (389-devel and 389-users) and pagure issues where he is subscribed/mentioned. Email sent to fedoraproject alias is also not delivered.

Could you please look into that?
Thanks!


Other people did complain about that, and it seems that the link between fedora servers and RH ones (who act as MX) is blocked. IT did change the routing to go to 10.3.163.31 (iad2), but I see there is still mention of 10.5.126.11 (phx2).

Can you give the error message to confirm ?

I don't have an error message. Email sent to the alias didn't return any delivery failure. Email sent from RH directly to that email works.

Did you send the email to the alias yourself? Do you use gmail?
Because if so, gmail does deduplication and since the email is in your sent items folder, if won't show up in the inbox.

I'm going to send you a test email to the @fp.o alias to see if that changes anything.

i can confirm that at the moment the forwarding for fedoraproject.org e-mail does not to work

E-mails send by gmail to <username>@fedoraproject.org get the following status message

"451 4.3.0 Could not connect to other SMTP server 10.5.126.11: Connection timed out "

clearly an internal IP ... so the e-mail is accepted by the mx redhat servers but seems they are not able to forward them

Test e-mails send from other domains do not get/send a status message (have not access to my own serverlogs at the moment) - maybe because they should have at least 24h to re-try ...

This is what I see in my server logs if that helps anyone:

Jun 17 13:11:25 ambre postfix/smtp[27388]: 05695C1F87B0: to=<elkris@fedoraproject.org>, relay=smtp....:587, delay=0.84, delays=0.03/0.01/0.47/0.33, dsn=2.6.0, status=sent (250 2.6.0 <20200617111124.GC16517@pingoured.fr> [InternalId=19421842115251, Hostname=DAG4EX1.mxp8.local] 1627 bytes in 0.148, 10.699 KB/sec Queued mail for delivery)

Did you send the email to the alias yourself? Do you use gmail?

Sorry for the confusion, this is not my alias, but of another user. I did use gmail to send test emails to his alias and a private email.

Because if so, gmail does deduplication and since the email is in your sent items folder, if won't show up in the inbox.
I'm going to send you a test email to the @fp.o alias to see if that changes anything.

Thanks, I'm going to check with him (as he can't receive updates from this ticket :) )

Thanks, I'm going to check with him (as he can't receive updates from this ticket :) )

I sent the test email to both you and @elkris so you should receive it as well :)

I tested as well from my RH mail address and personal mail address. RH IT puppet configuration do seems to still use the old IP in a few postfix configuration files, so I guess one was forgotten.

I also didn't receive it

misc can I get a list of those files so I can ask internal to fix this? Or can you do so?

Metadata Update from @smooge:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

2 months ago

Metadata Update from @smooge:
- Issue status updated to: Open (was: Closed)

2 months ago

Sorry closed the wrong ticket.

The internal servers trying to route email to down servers have been found and re-educated. This problem should be fixed.. I will keep open for 24 hours for people to report more if it isnt

Metadata Update from @smooge:
- Issue assigned to smooge
- Issue priority set to: Waiting on Assignee (was: Needs Review)
- Issue tagged with: groomed, high-gain, high-trouble

2 months ago

Metadata Update from @kevin:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

2 months ago

I still don't get any mails for elkris@fedoraproject.org or via pgure

The issue is not resolved. I still cannot receive emails. 'Unable to deliver message after multiple retries, giving up.'

Metadata Update from @vashirov:
- Issue status updated to: Open (was: Closed)

2 months ago

FWIW, I've tried sending mail to my @fedoraproject.org address from three senders:

  • my RH mail address
  • a googlemail address
  • my private domain

Only the one sent from RH made its way through so far. The logs for my private domain tell me this:

Jun 18 11:39:29 h2648324 postfix/smtp[3354410]: 2429310139B: host mx1.redhat.com[209.132.183.28] said: 451 4.3.0 Could not connect to other SMTP server 10.5.126.11: Connection timed out (in reply to RCPT TO command)

@smooge The 10.5.126.11 address resolves to bastion02.phx2.fedoraproject.org, it looks as if not all RH MTAs have gotten the memo about the move yet.

Update: The mail I sent from my private account got through meanwhile.

It looks like it is fixed now.

@elkris does you it work for you as well now?

@pingou - it works well for me now - mail go through from mult. Senders

Thanks @jsimon if @elkris confirms it's working, we'll close this ticket :)

@elkris does you it work for you as well now?

I didn't get the updates of this ticket although I am subscribed, so I would say no.

And if I send a mail from my private account to elkris@fedoraproject.org I do not receive it back

@elkris we seem to be blacklisted by your provider:

orig_to=<elkris@fedoraproject.org>, relay=none, delay=21347, delays=21347/0.1/0/0.01, dsn=4.0.0, status=deferred (delivery temporarily suspended: host mx02.t-online.de[194.25.134.9] refused to talk to me: 554 IP=38.145.60.11 - A problem occurred. (Ask your postmaster for help or to contact tosa@rx.t-online.de to clarify.) (BL))

can you contact them and ask them to clear us? or would you like us to?

I did contact them and they said they will reset "reputation" for 38.145.60.11 and now I did receive a bunch of emails from the past days.

But I do not know if more ip addresses are affected and need attention.

looks like everything is working now

Metadata Update from @kevin:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

a month ago

Login to comment on this ticket.

Metadata