#8983 Update atomic-reactor config to use flatpak-build-base for flatpak builds
Closed: Fixed 5 months ago by cverna. Opened 5 months ago by kalev.

Please update atomic-reactor config to use flatpak-build-base image for flatpak builds.

flatpak-build-base (https://bodhi.fedoraproject.org/updates/FEDORA-CONTAINER-2020-fae9f7062c) is a layered image that only differs from fedora:32 by removing /etc/rpm/macros.image-language-conf. See https://bugzilla.redhat.com/show_bug.cgi?id=1784607 for details (it's needed to get translations into flatpak builds that get otherwise stripped out by rpm).

The build in Bodhi is still pending to testing, but it should be possible to already start using it through the candidate registry. Please update flatpak base_image in https://pagure.io/fedora-infra/ansible/blob/master/f/inventory/group_vars/osbs_masters#_102 and change it to use candidate-registry.fedoraproject.org/flatpak-build-base:latest

Thanks,
Kalev


@kalev Once the update is pushed to testing, it should be available on candidate-registry.fp.o. But due to some issue it didn't get pushed last night. Is that what you are asking for?

Also, due to data center move we are bit stretched, so expect delayed replies.

Metadata Update from @mohanboddu:
- Issue priority set to: Waiting on Reporter (was: Needs Review)
- Issue tagged with: groomed, high-trouble, low-gain

5 months ago

No, that's not at all what I'm asking for here. It's a task for @cverna to update a configuration file.

Login to comment on this ticket.

Metadata
Related Pull Requests
  • #115 Merged 5 months ago