#8308 fas-clients not installable in f31-infra/f32-infra
Closed: Fixed 2 months ago by codeblock. Opened 2 months ago by kevin.

[root@f31-test ~][PROD]# dnf install fas-clients
Last metadata expiration check: 1 day, 22:50:55 ago on Sat 19 Oct 2019 06:07:09 PM UTC.
Error:
Problem: conflicting requests
- nothing provides libselinux-python needed by fas-clients-0.10.2-3.fc31.infra.noarch
- nothing provides /usr/bin/python33 needed by fas-clients-0.10.2-4.fc31.infra.noarch
- nothing provides libselinux-python needed by fas-clients-0.10.2-4.fc31.infra.noarch
(try to add '--skip-broken' to skip uninstallable packages)

libselinux-python has been replaced by python3-libselinux in f31+
and it should probibly depend on python3 not 33.


this is preventing me updating the openQA boxes to F31.

Yeah, well, it was preventing a lot of things. And it's surprising to me that I was able to get the client working on py3 at all. But these issues were just specfile issues.

In any case, there's a new build in infra-stg that should fix the dep issues. Reopen if they persist.

Metadata Update from @codeblock:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

2 months ago

Login to comment on this ticket.

Metadata