#7942 Planned Outage - fedoraproject.org/wiki - 2019-06-27 21:00 UTC
Closed: Fixed 5 months ago by kevin. Opened 5 months ago by kevin.

Planned Outage - fedoraproject.org/wiki - 2019-06-27 21:00 UTC

There will be an outage starting at 2019-06-27 21:00 UTC ,
which will last approximately 2 hours.

To convert UTC to your local time, take a look at
http://fedoraproject.org/wiki/Infrastructure/UTCHowto
or run:

date -d '2019-06-27 21:00UTC'

Reason for outage:

We will be updating the nodes running mediawiki to Fedora 30 and thus also upgrading mediawiki to a newer version. The last scheduled upgrade was aborted due to some issues found in staging. These issues have been fixed and we are ready to finally upgrade.

Affected Services:

https://fedoraproject.org/wiki

Ticket Link:

https://pagure.io/fedora-infrastructure/issue/7942

Please join #fedora-admin or #fedora-noc on irc.freenode.net
or add comments to the ticket for this outage above.


Not sure if this is the place to report, but still getting a 500 issue when going to user preferences in stg:

https://stg.fedoraproject.org/wiki/Special:Preferences

On my local install on fedora 30 when testing the theme issues, i got the following debug message:

Fatal error: Cannot declare trait OOUI\AccessKeyedElement, because the name is already in use in /usr/share/php/OOUI/mixins/AccessKeyedElement.php on line 14

Sigh, I missed this comment here... yes, it's happening and we need to figure it out.

I'll open a new ticket for it tho... this outage is over.

Metadata Update from @kevin:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

5 months ago

@ryanlerch got it figured, should be fixed now.

Need to modify /srv/web/fp-wiki/vendor/oojs-shared/widgets/InputWidget.php to have require_once for /usr/share/php/OOUI/mixins/AccessKeyedElement.php instead of require...

Login to comment on this ticket.

Metadata