#7748 PSA: Don't upgrade hawkey on any of Bodhi's systems
Closed: Fixed 4 months ago by kevin. Opened 5 months ago by bowlofeggs.

I just discovered that there has been a backwards incompatible update to hawkey[0] on Fedora 29 that breaks Bodhi. It's important that we avoid applying this update to Bodhi's servers or they will be unable to compose repos (I think that's all Bodhi uses it for, but haven't done a thorough analysis to be sure).

[0] https://github.com/fedora-infra/bodhi/issues/3193


It is only used in the Compose process, during the checks of generated repositories.

I just tested a test build from https://copr.fedorainfracloud.org/coprs/jrohel/libdnf-bodhi/ in staging, and it seems to work.

Now we just need them to make a real build.

The same DNF regression also affects Koschei, but it should be already fixed in libdnf-0.31.0-3.fc29 (currently in updates-testing).

We can close this once https://bodhi.fedoraproject.org/updates/FEDORA-2019-74e1dd1341 goes stable (it is currently batched, so we can probably close this tomorrow).

It's stable. Thanks everyone!

:chestnut:

Metadata Update from @kevin:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

4 months ago

Login to comment on this ticket.

Metadata