#1298 Some php stuff missed on PPC builders
Closed: Fixed None Opened 13 years ago by hubbitus.

I have the same question what Remi Collet ask [1] in 01 March.

I ask about it in devel list, and Kevin Fenzy say what I must file ticket there.[3]

It is in archive I can't answer. And I have similar problem with PPC
build [2] (this build on i586 successful):
{{{
State Changed: clean
ERROR: Command failed:
# /usr/bin/yum --installroot
/var/lib/mock/fedora-5-ppc-epel-e3925848eafb7e09061ed5eae74be9bc98a2f211/root/
install 'php-pear >= 1.4.7' 'php-devel >= 5.0.0'
php-5.1.6-20.el5_2.1.ppc from rhel5-base has depsolving problems
--> Missing Dependency: php-cli = 5.1.6-20.el5_2.1 is needed by
package php-5.1.6-20.el5_2.1.ppc (rhel5-base)
php-5.1.6-20.el5_2.1.ppc from rhel5-base has depsolving problems
--> Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
package php-5.1.6-20.el5_2.1.ppc (rhel5-base)
php-5.1.6-20.el5_2.1.ppc from rhel5-base has depsolving problems
--> Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
package php-5.1.6-20.el5_2.1.ppc (rhel5-base)
Error: Missing Dependency: php-cli = 5.1.6-20.el5_2.1 is needed by
package php-5.1.6-20.el5_2.1.ppc (rhel5-base)
Error: Missing Dependency: php-common = 5.1.6-20.el5_2.1 is needed by
package php-5.1.6-20.el5_2.1.ppc (rhel5-base)
}}}
Can I solve this problem itself?

[1] [http://www.mail-archive.com/epel-devel-list@redhat.com/msg02031.html]
[2] [http://buildsys.fedoraproject.org/logs/fedora-5-epel/1824-php-pecl-runkit-0.9-10.CVS20090215.el5/ppc/job.log]
[3] [http://article.gmane.org/gmane.linux.redhat.fedora.devel/108385]


When this happened with another package, this was the solution:

Remove the version specific build-requires; yum/mock on EL5 has multiple versions of packages available and gets the lowest nevra for a package if a minimal version build-requires is used.

There more strange I found.
One my very-very similar pachage php-pecl-imagick was built normally (I do not known how provide link on this build which was be made by plague):
$ plague-client detail 1361

Detail for Job ID 1361 (php-pecl-imagick):

Source: php-pecl-imagick-2_2_1-3_el5
Target: fedora-5-epel
Submitter: pahan@hubbitus.spb.su
Status: needsign/
Archjobs:
ppc: ppc2.fedora.redhat.com done/done
x86_64: xenbuilder2.fedora.redhat.com done/done
i386: xenbuilder2.fedora.redhat.com done/done

Also JobID - 1364.

, but now it is also failed when submited by koji http://koji.fedoraproject.org/koji/taskinfo?taskID=1277441 ! Please note, it is not changed at all!

So, may be it is koji problem?

And if I remove version specification in BuildRequires by your suggestion it is bult successfully - http://koji.fedoraproject.org/koji/taskinfo?taskID=1277775

So, what conclusion from that? It is not error in build system? I can't provide versions in [Build]Requires? I should delete it conditionaly fo PPC arch of Epel builds? Or I something do compleately wrong there?

the issue needing to not use versioned BuildRequires was a yum bug. this has been fixed now. the builders all got a yum update.

Login to comment on this ticket.

Metadata