#1191 Deploy Transifex 0.5-devel (hg tip) on publictest

Created 7 years ago by glezos

Requesting an instance of Transifex 0.5-devel (the Django Branch (tm)) on a publictest server, in order to hammer it to shape for translation statistics for Fedora 11.

Source: http://code.transifex.org/mainline

The action requested is to checkout the source directly from hg on a publictest server and follow installation procedure to install dependencies:

http://docs.transifex.org/intro/install.html

Action plan:

We could need all the time we'll have to test/polish before the string freeze of 10-Mar-2009.

Tx 0.5-final is scheduled to be released in ~1 month with full submission support. If everything goes well, we could even have 0.5 with submissions over ssh-agent in time (still unsure).

More info will be sent on Infra-list.

publictest14 should be suitable for the needs of the project, so feel free to use that for the testing of Transifex.

Hey nigel, I've been pinged by.. well a lot of people on this. So I figure I'll work on it while I'm awake, and you can work on it while you're awake and we'll tag-team it until its working :)

I'll track everything I've done in here so we don't duplicate effort.

the easy_install stuff went fine except for django-authopenid which it: http://code.google.com/p/django-authopenid/issues/detail?id=48#c0 so I grabbed the code from head and installed it.

Deployed with wsgi but not yet working properly.

Ok, seems it was missing a dep:

python-pygments

Ok, its mostly working:

http://publictest14.fedoraproject.org/tx/

One issue. When you click on login it takes you to:

http://publictest14.fedoraproject.org/tx/account/signin/?next=/

Instead it should take you to:

http://publictest14.fedoraproject.org/tx/account/signin/?next=/tx/

It's redirecting us to the wrong location. but manually fixing it seems to work.

Replying to [comment:8 mmcgrath]:

http://publictest14.fedoraproject.org/tx/account/signin/?next=/tx/

K, Magus (of #django) and I figured out what the problem here was. On line 35 in templates/base.html there's a reference to request.path_info which should actually be request.path. I've made the change on pt8, we'll need to get that commit into the upstream tx repo.

Can we setup email delivery? SMTP needed at settings.py.

Thanks guys, working on this now.

this is long done.

Login to comment on this ticket.