Commit 471a2b2 Replace the outdated react-select-2 with react-select

3 files Authored and Committed by abompard 6 months ago
Replace the outdated react-select-2 with react-select

    
 1 @@ -1,8 +1,8 @@
 2   import React from 'react';
 3 - import Select from 'react-select-2';
 4 + import Select from 'react-select';
 5   import PropTypes from 'prop-types';
 6   import VisibilitySelect from '../VisibilitySelect';
 7 - import 'react-select-2/dist/css/react-select-2.css';
 8 + import 'react-select/dist/react-select.css';
 9   
10   
11   export default class WidgetSelectDialog extends React.Component {
  1 @@ -11045,173 +11045,14 @@
  2           }
  3         }
  4       },
  5 -     "react-select-2": {
  6 -       "version": "2.0.11",
  7 -       "resolved": "https://registry.npmjs.org/react-select-2/-/react-select-2-2.0.11.tgz",
  8 -       "integrity": "sha1-v7mJaKZz5Vll0ngXVGmFzyhQQBM=",
  9 +     "react-select": {
 10 +       "version": "1.2.1",
 11 +       "resolved": "https://registry.npmjs.org/react-select/-/react-select-1.2.1.tgz",
 12 +       "integrity": "sha512-vaCgT2bEl+uTyE/uKOEgzE5Dc/wLtzhnBvoHCeuLoJWc4WuadN6WQDhoL42DW+TziniZK2Gaqe/wUXydI3NSaQ==",
 13         "requires": {
 14 -         "babel-cli": "6.26.0",
 15 -         "babel-core": "6.26.0",
 16 -         "babel-loader": "6.4.1",
 17 -         "babel-plugin-transform-decorators": "6.24.1",
 18 -         "babel-plugin-transform-decorators-legacy": "1.3.4",
 19 -         "babel-preset-es2015": "6.24.1",
 20 -         "babel-preset-react": "6.24.1",
 21 -         "babel-preset-stage-0": "6.24.1",
 22           "classnames": "2.2.5",
 23 -         "image-webpack-loader": "3.6.0",
 24 -         "jest": "19.0.2",
 25 -         "jest-cli": "19.0.2",
 26 -         "less": "2.7.3",
 27 -         "less-loader": "4.0.5",
 28 -         "lodash": "https://registry.npmjs.org/lodash/-/lodash-4.17.4.tgz",
 29 -         "manifest-revision-webpack-plugin": "0.4.1",
 30 -         "postcss-assets": "4.2.0",
 31 -         "postcss-browser-reporter": "0.5.0",
 32 -         "postcss-cssnext": "2.11.0",
 33 -         "postcss-import": "9.1.0",
 34 -         "postcss-loader": "1.3.3",
 35 -         "postcss-mixins": "5.4.1",
 36 -         "postcss-reporter": "3.0.0",
 37 -         "postcss-url": "6.3.1",
 38 -         "react": "15.6.2",
 39 -         "react-dom": "15.6.2",
 40 -         "react-highlight-words": "0.6.0",
 41 -         "react-input-autosize": "1.2.0",
 42 -         "style-loader": "0.16.1",
 43 -         "url-loader": "0.5.9",
 44 -         "webpack": "2.7.0",
 45 -         "webpack-dev-server": "2.11.1"
 46 -       },
 47 -       "dependencies": {
 48 -         "acorn": {
 49 -           "version": "5.4.1",
 50 -           "resolved": "https://registry.npmjs.org/acorn/-/acorn-5.4.1.tgz",
 51 -           "integrity": "sha512-XLmq3H/BVvW6/GbxKryGxWORz1ebilSsUDlyC27bXhWGWAZWkGwS6FLHjOlwFXNFoWFQEO/Df4u0YYd0K3BQgQ=="
 52 -         },
 53 -         "ajv": {
 54 -           "version": "4.11.8",
 55 -           "resolved": "https://registry.npmjs.org/ajv/-/ajv-4.11.8.tgz",
 56 -           "integrity": "sha1-gv+wKynmYq5TvcIK8VlHcGc5xTY=",
 57 -           "requires": {
 58 -             "co": "4.6.0",
 59 -             "json-stable-stringify": "1.0.1"
 60 -           }
 61 -         },
 62 -         "babel-loader": {
 63 -           "version": "6.4.1",
 64 -           "resolved": "https://registry.npmjs.org/babel-loader/-/babel-loader-6.4.1.tgz",
 65 -           "integrity": "sha1-CzQRLVsHSKjc2/Uaz2+b1C1QuMo=",
 66 -           "requires": {
 67 -             "find-cache-dir": "0.1.1",
 68 -             "loader-utils": "0.2.17",
 69 -             "mkdirp": "0.5.1",
 70 -             "object-assign": "https://registry.npmjs.org/object-assign/-/object-assign-4.1.1.tgz"
 71 -           }
 72 -         },
 73 -         "co": {
 74 -           "version": "4.6.0",
 75 -           "resolved": "https://registry.npmjs.org/co/-/co-4.6.0.tgz",
 76 -           "integrity": "sha1-bqa989hTrlTMuOR7+gvz+QMfsYQ="
 77 -         },
 78 -         "jest": {
 79 -           "version": "19.0.2",
 80 -           "resolved": "https://registry.npmjs.org/jest/-/jest-19.0.2.tgz",
 81 -           "integrity": "sha1-t5T6r4/0Yec4jyi+71WaVPILLBA=",
 82 -           "requires": {
 83 -             "jest-cli": "19.0.2"
 84 -           }
 85 -         },
 86 -         "jest-cli": {
 87 -           "version": "19.0.2",
 88 -           "resolved": "https://registry.npmjs.org/jest-cli/-/jest-cli-19.0.2.tgz",
 89 -           "integrity": "sha1-zDYgtirKxfLZOlSMtu9pfU7IVEM=",
 90 -           "requires": {
 91 -             "ansi-escapes": "1.4.0",
 92 -             "callsites": "2.0.0",
 93 -             "chalk": "1.1.3",
 94 -             "graceful-fs": "4.1.11",
 95 -             "is-ci": "1.1.0",
 96 -             "istanbul-api": "1.2.1",
 97 -             "istanbul-lib-coverage": "1.1.1",
 98 -             "istanbul-lib-instrument": "1.9.1",
 99 -             "jest-changed-files": "19.0.2",
100 -             "jest-config": "19.0.4",
101 -             "jest-environment-jsdom": "19.0.2",
102 -             "jest-haste-map": "19.0.2",
103 -             "jest-jasmine2": "19.0.2",
104 -             "jest-message-util": "19.0.0",
105 -             "jest-regex-util": "19.0.0",
106 -             "jest-resolve-dependencies": "19.0.0",
107 -             "jest-runtime": "19.0.4",
108 -             "jest-snapshot": "19.0.2",
109 -             "jest-util": "19.0.2",
110 -             "micromatch": "2.3.11",
111 -             "node-notifier": "5.2.1",
112 -             "slash": "1.0.0",
113 -             "string-length": "1.0.1",
114 -             "throat": "3.2.0",
115 -             "which": "1.3.0",
116 -             "worker-farm": "1.5.2",
117 -             "yargs": "6.6.0"
118 -           }
119 -         },
120 -         "style-loader": {
121 -           "version": "0.16.1",
122 -           "resolved": "https://registry.npmjs.org/style-loader/-/style-loader-0.16.1.tgz",
123 -           "integrity": "sha1-UOMlJY1OeEId2WgGNrQehmFZXRA=",
124 -           "requires": {
125 -             "loader-utils": "1.1.0"
126 -           },
127 -           "dependencies": {
128 -             "loader-utils": {
129 -               "version": "1.1.0",
130 -               "resolved": "https://registry.npmjs.org/loader-utils/-/loader-utils-1.1.0.tgz",
131 -               "integrity": "sha1-yYrvSIvM7aL/teLeZG1qdUQp9c0=",
132 -               "requires": {
133 -                 "big.js": "3.2.0",
134 -                 "emojis-list": "2.1.0",
135 -                 "json5": "0.5.1"
136 -               }
137 -             }
138 -           }
139 -         },
140 -         "supports-color": {
141 -           "version": "3.2.3",
142 -           "resolved": "https://registry.npmjs.org/supports-color/-/supports-color-3.2.3.tgz",
143 -           "integrity": "sha1-ZawFBLOVQXHYpklGsq48u4pfVPY=",
144 -           "requires": {
145 -             "has-flag": "1.0.0"
146 -           }
147 -         },
148 -         "webpack": {
149 -           "version": "2.7.0",
150 -           "resolved": "https://registry.npmjs.org/webpack/-/webpack-2.7.0.tgz",
151 -           "integrity": "sha512-MjAA0ZqO1ba7ZQJRnoCdbM56mmFpipOPUv/vQpwwfSI42p5PVDdoiuK2AL2FwFUVgT859Jr43bFZXRg/LNsqvg==",
152 -           "requires": {
153 -             "acorn": "5.4.1",
154 -             "acorn-dynamic-import": "2.0.2",
155 -             "ajv": "4.11.8",
156 -             "ajv-keywords": "1.5.1",
157 -             "async": "2.6.0",
158 -             "enhanced-resolve": "3.4.1",
159 -             "interpret": "1.1.0",
160 -             "json-loader": "0.5.7",
161 -             "json5": "0.5.1",
162 -             "loader-runner": "2.3.0",
163 -             "loader-utils": "0.2.17",
164 -             "memory-fs": "0.4.1",
165 -             "mkdirp": "0.5.1",
166 -             "node-libs-browser": "2.1.0",
167 -             "source-map": "0.5.7",
168 -             "supports-color": "3.2.3",
169 -             "tapable": "0.2.8",
170 -             "uglify-js": "2.8.29",
171 -             "watchpack": "1.4.0",
172 -             "webpack-sources": "1.1.0",
173 -             "yargs": "6.6.0"
174 -           }
175 -         }
176 +         "prop-types": "15.6.1",
177 +         "react-input-autosize": "2.2.1"
178         }
179       },
180       "react-sortable-hoc": {
1 @@ -18,7 +18,7 @@
2       "react-intl": "^2.4.0",
3       "react-linkify": "^0.2.1",
4       "react-redux": "^5.0.6",
5 -     "react-select-2": "^2.0.11",
6 +     "react-select": "^1.2.1",
7       "react-sortable-hoc": "^0.6.7",
8       "react-universal-component": "^2.5.5",
9       "reconnecting-eventsource": "^1.0.1",