#4 check if all packages that are currently filtered out with "all" are actually false positives
Closed: FIXED 2 years ago by decathorpe. Opened 2 years ago by decathorpe.

Below is a formatted and abridged version of the script output from running today's reports.

Every line like "Filtered out foo dependency: bar" should be checked manually - is it actually a false positive, and if so, the respective "all" override in overrides.json should be changed to only the values that are sufficient and necessary, to make sure any future "real" broken dependencies aren't ignored.


Update: removed packages that I have already manually verified

  • python3-importlib because of broken if dep with python3.8
  • 32-bit arm optimized OpenJDK on non-armv7hl arches

I manually verified the following false positives on ppc64le and s390x:

pkgconfig(Qt5WebEngine):

  • GoldenCheetah
  • digikam
  • kalgebra
  • kdepim-addons
  • mellowplayer
  • mscore
  • orion
  • pyqtwebengine
  • python-qt5
  • rssguard

cmake(Qt5WebEngine)

  • akregator
  • blogilo
  • ghostwriter
  • grantlee-editor
  • kf5-messagelib
  • kmail
  • konqueror
  • kontact
  • libquentier
  • quentier

cmake(Qt5WebEngineWidgets)

  • akregator
  • blogilo
  • grantlee-editor
  • libksysguard
  • libquentier
  • parley
  • qevercloud
  • quentier

qt5-qtwebengine-devel

  • bibletime
  • calibre
  • cutter-re
  • fcitx-libpinyin
  • gpsbabel
  • kbibtex
  • kdepim-runtime
  • kdeplasma-addons
  • kf5-akonadi-contacts
  • kiwix-desktop
  • ktp-text-ui
  • libkgapi
  • luminance-hdr
  • mediaconch
  • mscore
  • nextcloud-client
  • otter-browser
  • qt5-qtwebview
  • root
  • ugene

Metadata Update from @decathorpe:
- Issue close_status updated to: FIXED
- Issue status updated to: Closed (was: Open)

2 years ago

Login to comment on this ticket.

Metadata