#509 Make KDE software listing comprehensive
Closed 2 years ago by appadeia. Opened 2 years ago by appadeia.
appadeia/fedora-comps sorted-kde  into  main

file modified
+1046 -236
@@ -3027,274 +3027,1078 @@ 

        </packagelist>

    </group>

    <group>

-     <id>kde-apps</id>

-     <_name>KDE Applications</_name>

-     <_description>A set of commonly used KDE applications</_description>

+     <id>kde-accessibility</id>

+     <_name>KDE Accessibility Tools</_name>

+     <_description>Accessibility tools maintained by KDE</_description>

      <default>false</default>

-     <uservisible>false</uservisible>

+     <uservisible>true</uservisible>

      <packagelist>

-       <packagereq>ark</packagereq>

-       <packagereq>digikam</packagereq>

-       <packagereq>kde-connect</packagereq>

-       <packagereq>kmahjongg</packagereq>

-       <packagereq>kmines</packagereq>

-       <packagereq>kolourpaint</packagereq>

-       <packagereq>konversation</packagereq>

-       <packagereq>kpat</packagereq>

-       <packagereq>krdc</packagereq>

-       <packagereq>krfb</packagereq>

-       <packagereq>krusader</packagereq>

-       <packagereq>ktorrent</packagereq>

+       <packagereq type="optional">kmouth</packagereq>

      </packagelist>

    </group>

    <group>

-     <id>kde-desktop</id>

-     <_name>KDE</_name>

-     <_description>The KDE Plasma Workspaces, a highly-configurable graphical user interface which includes a panel, desktop, system icons and desktop widgets, and many powerful KDE applications.</_description>

+     <id>kde-addons</id>

+     <_name>KDE Addons</_name>

+     <_description>Addons to KDE software maintained by KDE</_description>

      <default>false</default>

-     <uservisible>false</uservisible>

+     <uservisible>true</uservisible>

      <packagelist>

-       <packagereq>abrt-desktop</packagereq>

-       <packagereq>adwaita-gtk2-theme</packagereq>

-       <packagereq>akregator</packagereq>

-       <packagereq>bluedevil</packagereq>

-       <packagereq>breeze-icon-theme</packagereq>

-       <packagereq>colord-kde</packagereq>

-       <packagereq>cups-pk-helper</packagereq>

-       <packagereq>dnfdragora</packagereq>

-       <packagereq>dolphin</packagereq>

-       <packagereq>earlyoom</packagereq>

-       <packagereq>firewall-config</packagereq>

-       <packagereq>glibc-all-langpacks</packagereq>

-       <packagereq>gnome-keyring-pam</packagereq>

-       <packagereq>gwenview</packagereq>

-       <packagereq>initial-setup-gui</packagereq>

-       <packagereq>kaddressbook</packagereq>

-       <packagereq>kamera</packagereq>

-       <packagereq>kcalc</packagereq>

-       <packagereq>kcharselect</packagereq>

-       <packagereq>kcm_systemd</packagereq>

-       <packagereq>kcolorchooser</packagereq>

-       <packagereq>kde-gtk-config</packagereq>

-       <packagereq>kde-partitionmanager</packagereq>

-       <packagereq>kde-print-manager</packagereq>

-       <packagereq>kde-settings-pulseaudio</packagereq>

-       <packagereq>kdegraphics-thumbnailers</packagereq>

-       <packagereq>kdeplasma-addons</packagereq>

-       <packagereq>kdialog</packagereq>

-       <packagereq>kdnssd</packagereq>

-       <packagereq>keditbookmarks</packagereq>

-       <packagereq>kf5-akonadi-server</packagereq>

-       <packagereq>kf5-akonadi-server-mysql</packagereq>

-       <packagereq>kf5-baloo-file</packagereq>

-       <packagereq>kf5-kipi-plugins</packagereq>

-       <packagereq>kfind</packagereq>

-       <packagereq>kget</packagereq>

-       <packagereq>kgpg</packagereq>

-       <packagereq>khelpcenter</packagereq>

-       <packagereq>khotkeys</packagereq>

-       <packagereq>kinfocenter</packagereq>

-       <packagereq>kmag</packagereq>

-       <packagereq>kmail</packagereq>

-       <packagereq>kmenuedit</packagereq>

-       <packagereq>kmousetool</packagereq>

-       <packagereq>kmouth</packagereq>

-       <packagereq>konsole5</packagereq>

-       <packagereq>kontact</packagereq>

-       <packagereq>korganizer</packagereq>

-       <packagereq>kruler</packagereq>

-       <packagereq>kscreen</packagereq>

-       <packagereq>kscreenlocker</packagereq>

-       <packagereq>ksshaskpass</packagereq>

-       <packagereq>ksysguard</packagereq>

-       <packagereq>kwalletmanager5</packagereq>

-       <packagereq>kwebkitpart</packagereq>

-       <packagereq>kwin</packagereq>

-       <packagereq>kwrite</packagereq>

-       <packagereq>NetworkManager-config-connectivity-fedora</packagereq>

-       <packagereq>pam-kwallet</packagereq>

-       <packagereq>phonon-qt5-backend-gstreamer</packagereq>

-       <packagereq>pinentry-qt</packagereq>

-       <packagereq>plasma-breeze</packagereq>

-       <packagereq>plasma-desktop-doc</packagereq>

-       <packagereq>plasma-discover</packagereq>

-       <packagereq>plasma-drkonqi</packagereq>

-       <packagereq>plasma-nm</packagereq>

-       <packagereq>plasma-nm-l2tp</packagereq>

-       <packagereq>plasma-nm-openconnect</packagereq>

-       <packagereq>plasma-nm-openswan</packagereq>

-       <packagereq>plasma-nm-openvpn</packagereq>

-       <packagereq>plasma-nm-pptp</packagereq>

-       <packagereq>plasma-nm-vpnc</packagereq>

-       <packagereq>plasma-pa</packagereq>

-       <packagereq>plasma-pk-updates</packagereq>

-       <packagereq>plasma-user-manager</packagereq>

-       <packagereq>plasma-workspace-geolocation</packagereq>

-       <packagereq>plasma-workspace-xorg</packagereq>

-       <packagereq>polkit-kde</packagereq>

-       <packagereq>qt5-qtdeclarative</packagereq>

-       <packagereq>spectacle</packagereq>

-       <packagereq>xorg-x11-drv-libinput</packagereq>

-       <packagereq type="mandatory">plasma-desktop</packagereq>

-       <packagereq type="mandatory">plasma-workspace</packagereq>

-       <packagereq type="mandatory">qt5-qtbase-gui</packagereq>

-       <packagereq type="mandatory">sddm</packagereq>

-       <packagereq type="mandatory">sddm-breeze</packagereq>

-       <packagereq type="mandatory">sddm-kcm</packagereq>

-       <packagereq type="conditional" requires="at-spi2-core">qt-at-spi</packagereq>

+       <packagereq type="optional">kdeedu-data</packagereq>

+       <packagereq type="optional">kdegraphics-mobipocket</packagereq>

+       <packagereq type="optional">kdegraphics-mobipocket-devel</packagereq>

+       <packagereq type="optional">kdegraphics-thumbnailers</packagereq>

+       <packagereq type="optional">kdenetwork-filesharing</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-development-tools</id>

+     <_name>KDE Development Tools</_name>

+     <_description>Development tools maintained by KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">cervisia</packagereq>

+       <packagereq type="default">clazy</packagereq>

+       <packagereq type="optional">heaptrack</packagereq>

+       <packagereq type="optional">kapptemplate</packagereq>

+       <packagereq type="default">kcachegrind</packagereq>

+       <packagereq type="optional">kcachegrind-converters</packagereq>

+       <packagereq type="optional">kde-apps-rpm-macros</packagereq>

+       <packagereq type="optional">kde-dev-scripts</packagereq>

+       <packagereq type="optional">kde-dev-utils</packagereq>

+       <packagereq type="optional">kde-dev-utils-common</packagereq>

+       <packagereq type="optional">kde-filesystem</packagereq>

+       <packagereq type="default">kdevelop</packagereq>

+       <packagereq type="optional">kdevelop-devel</packagereq>

+       <packagereq type="default">kdevelop-pg-qt</packagereq>

+       <packagereq type="optional">kdevelop-pg-qt-devel</packagereq>

+       <packagereq type="optional">kdevelop-php</packagereq>

+       <packagereq type="default">kdevelop-python</packagereq>

+       <packagereq type="optional">kdiff3</packagereq>

+       <packagereq type="optional">kompare</packagereq>

+       <packagereq type="optional">kompare-devel</packagereq>

+       <packagereq type="default">lokalize</packagereq>

+       <packagereq type="optional">poxml</packagereq>

+       <packagereq type="optional">rkward</packagereq>

+       <packagereq type="default">rocs</packagereq>

+       <packagereq type="optional">rocs-devel</packagereq>

+       <packagereq type="optional">umbrello</packagereq>

      </packagelist>

    </group>

    <group>

      <id>kde-education</id>

-     <_name>KDE Educational applications</_name>

-     <_description>KDE Educational applications</_description>

+     <_name>KDE Educational Apps</_name>

+     <_description>Educational apps maintained by KDE</_description>

      <default>false</default>

-     <uservisible>false</uservisible>

+     <uservisible>true</uservisible>

      <packagelist>

-       <packagereq>blinken</packagereq>

-       <packagereq>cantor</packagereq>

-       <packagereq>kalgebra</packagereq>

-       <packagereq>kalzium</packagereq>

-       <packagereq>kanagram</packagereq>

-       <packagereq>kbruch</packagereq>

-       <packagereq>kgeography</packagereq>

-       <packagereq>khangman</packagereq>

-       <packagereq>kig</packagereq>

-       <packagereq>kiten</packagereq>

-       <packagereq>klettres</packagereq>

-       <packagereq>kmplot</packagereq>

-       <packagereq>kstars</packagereq>

-       <packagereq>ktouch</packagereq>

-       <packagereq>kturtle</packagereq>

-       <packagereq>kwordquiz</packagereq>

-       <packagereq>marble</packagereq>

-       <packagereq>parley</packagereq>

-       <packagereq>rocs</packagereq>

-       <packagereq>step</packagereq>

-     </packagelist>

-   </group>

-   <group>

-     <id>kde-media</id>

-     <_name>KDE Multimedia support</_name>

-     <_description>Multimedia support for KDE</_description>

+       <packagereq type="optional">artikulate</packagereq>

+       <packagereq type="optional">cantor</packagereq>

+       <packagereq type="optional">cantor-devel</packagereq>

+       <packagereq type="optional">cantor-R</packagereq>

+       <packagereq type="default">kalgebra</packagereq>

+       <packagereq type="optional">kalzium</packagereq>

+       <packagereq type="optional">kalzium-devel</packagereq>

+       <packagereq type="optional">kbruch</packagereq>

+       <packagereq type="default">kgeography</packagereq>

+       <packagereq type="optional">kig</packagereq>

+       <packagereq type="optional">klettres</packagereq>

+       <packagereq type="optional">kmplot</packagereq>

+       <packagereq type="optional">ktouch</packagereq>

+       <packagereq type="default">kturtle</packagereq>

+       <packagereq type="optional">LabPlot</packagereq>

+       <packagereq type="default">marble</packagereq>

+       <packagereq type="optional">marble-astro</packagereq>

+       <packagereq type="optional">marble-astro-devel</packagereq>

+       <packagereq type="optional">marble-common</packagereq>

+       <packagereq type="default">marble-qt</packagereq>

+       <packagereq type="optional">marble-widget</packagereq>

+       <packagereq type="optional">marble-widget-data</packagereq>

+       <packagereq type="optional">marble-widget-devel</packagereq>

+       <packagereq type="optional">marble-widget-qt5</packagereq>

+       <packagereq type="optional">marble-widget-qt5-devel</packagereq>

+       <packagereq type="optional">minuet</packagereq>

+       <packagereq type="optional">minuet-data</packagereq>

+       <packagereq type="optional">minuet-devel</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-games</id>

+     <_name>KDE Games</_name>

+     <_description>Games maintained by KDE</_description>

      <default>false</default>

-     <uservisible>false</uservisible>

+     <uservisible>true</uservisible>

      <packagelist>

-       <packagereq>dragon</packagereq>

-       <packagereq>juk</packagereq>

-       <packagereq>k3b</packagereq>

-       <packagereq>kamoso</packagereq>

+       <packagereq type="default">blinken</packagereq>

+       <packagereq type="default">bomber</packagereq>

+       <packagereq type="default">bovo</packagereq>

+       <packagereq type="default">granatier</packagereq>

+       <packagereq type="default">kajongg</packagereq>

+       <packagereq type="default">kanagram</packagereq>

+       <packagereq type="default">kapman</packagereq>

+       <packagereq type="default">katomic</packagereq>

+       <packagereq type="default">kblackbox</packagereq>

+       <packagereq type="default">kblocks</packagereq>

+       <packagereq type="default">kbounce</packagereq>

+       <packagereq type="default">kbrickbuster</packagereq>

+       <packagereq type="default">kdiamond</packagereq>

+       <packagereq type="default">kfourinline</packagereq>

+       <packagereq type="default">kgoldrunner</packagereq>

+       <packagereq type="default">khangman</packagereq>

+       <packagereq type="default">kigo</packagereq>

+       <packagereq type="default">killbots</packagereq>

+       <packagereq type="default">kiriki</packagereq>

+       <packagereq type="default">kjots</packagereq>

+       <packagereq type="default">kjumpingcube</packagereq>

+       <packagereq type="default">klickety</packagereq>

+       <packagereq type="default">klines</packagereq>

+       <packagereq type="default">kmahjongg</packagereq>

+       <packagereq type="default">kmines</packagereq>

+       <packagereq type="default">knavalbattle</packagereq>

+       <packagereq type="default">knetwalk</packagereq>

+       <packagereq type="default">kolf</packagereq>

+       <packagereq type="default">kollision</packagereq>

+       <packagereq type="default">konquest</packagereq>

+       <packagereq type="default">kpat</packagereq>

+       <packagereq type="default">kreversi</packagereq>

+       <packagereq type="default">kshisen</packagereq>

+       <packagereq type="default">ksirk</packagereq>

+       <packagereq type="default">ksnakeduel</packagereq>

+       <packagereq type="default">kspaceduel</packagereq>

+       <packagereq type="default">ksquares</packagereq>

+       <packagereq type="default">kstars</packagereq>

+       <packagereq type="default">ksudoku</packagereq>

+       <packagereq type="default">ktuberling</packagereq>

+       <packagereq type="default">kubrick</packagereq>

+       <packagereq type="default">lskat</packagereq>

+       <packagereq type="default">rsibreak</packagereq>

+       <packagereq type="default">step</packagereq>

+       <packagereq type="default">sweeper</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-graphics</id>

+     <_name>KDE Graphics</_name>

+     <_description>Graphics software maintained by KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="default">digikam</packagereq>

+       <packagereq type="optional">digikam-devel</packagereq>

+       <packagereq type="optional">digikam-doc</packagereq>

+       <packagereq type="default">gwenview</packagereq>

+       <packagereq type="optional">ikona</packagereq>

+       <packagereq type="optional">ikona-cli</packagereq>

+       <packagereq type="optional">ikona-cli-bash-completions</packagereq>

+       <packagereq type="optional">ikona-cli-fish-completions</packagereq>

+       <packagereq type="optional">ikona-cli-zsh-completions</packagereq>

+       <packagereq type="optional">kgraphviewer</packagereq>

+       <packagereq type="optional">kgraphviewer-devel</packagereq>

+       <packagereq type="default">kolourpaint</packagereq>

+       <packagereq type="default">kphotoalbum</packagereq>

+       <packagereq type="default">krita</packagereq>

+       <packagereq type="optional">kruler</packagereq>

+       <packagereq type="optional">skanlite</packagereq>

+       <packagereq type="default">spectacle</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-network</id>

+     <_name>KDE Networking</_name>

+     <_description>Networking software maintained by KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">akregator</packagereq>

+       <packagereq type="optional">blogilo</packagereq>

+       <packagereq type="optional">choqok</packagereq>

+       <packagereq type="optional">choqok-devel</packagereq>

+       <packagereq type="default">falkon</packagereq>

+       <packagereq type="optional">falkon-gnome-keyring</packagereq>

+       <packagereq type="optional">falkon-kde</packagereq>

+       <packagereq type="default">kde-connect</packagereq>

+       <packagereq type="optional">kde-connect-devel</packagereq>

+       <packagereq type="optional">kde-connect-nautilus</packagereq>

+       <packagereq type="optional">kdeconnectd</packagereq>

+       <packagereq type="optional">kget</packagereq>

+       <packagereq type="optional">konqueror</packagereq>

+       <packagereq type="optional">konqueror-devel</packagereq>

+       <packagereq type="default">konversation</packagereq>

+       <packagereq type="optional">kopete</packagereq>

+       <packagereq type="optional">kopete-devel</packagereq>

+       <packagereq type="optional">krdc</packagereq>

+       <packagereq type="optional">krdc-devel</packagereq>

+       <packagereq type="optional">krfb</packagereq>

+       <packagereq type="default">ktorrent</packagereq>

+       <packagereq type="optional">ktp-accounts-kcm</packagereq>

+       <packagereq type="optional">ktp-approver</packagereq>

+       <packagereq type="optional">ktp-auth-handler</packagereq>

+       <packagereq type="optional">ktp-common-internals</packagereq>

+       <packagereq type="optional">ktp-common-internals-devel</packagereq>

+       <packagereq type="optional">ktp-contact-list</packagereq>

+       <packagereq type="optional">ktp-contact-runner</packagereq>

+       <packagereq type="optional">ktp-desktop-applets</packagereq>

+       <packagereq type="optional">ktp-filetransfer-handler</packagereq>

+       <packagereq type="optional">ktp-kded-integration-module</packagereq>

+       <packagereq type="optional">ktp-send-file</packagereq>

+       <packagereq type="optional">ktp-text-ui</packagereq>

+       <packagereq type="optional">telepathy-logger-qt</packagereq>

+       <packagereq type="optional">telepathy-logger-qt-devel</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-multimedia</id>

+     <_name>KDE Multimedia</_name>

+     <_description>Multimedia software maintained by KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">amarok</packagereq>

+       <packagereq type="optional">amarok-doc</packagereq>

+       <packagereq type="optional">amarok-utils</packagereq>

+       <packagereq type="optional">dragon</packagereq>

+       <packagereq type="default">elisa-player</packagereq>

+       <packagereq type="optional">juk</packagereq>

+       <packagereq type="optional">k3b</packagereq>

+       <packagereq type="optional">k3b-devel</packagereq>

+       <packagereq type="optional">kamera</packagereq>

+       <packagereq type="default">kamoso</packagereq>

+       <packagereq type="optional">kmix</packagereq>

+       <packagereq type="optional">kmplayer</packagereq>

+       <packagereq type="optional">kscd</packagereq>

+       <packagereq type="optional">kwave</packagereq>

+       <packagereq type="optional">kwave-doc</packagereq>

      </packagelist>

    </group>

    <group>

      <id>kde-office</id>

      <_name>KDE Office</_name>

-     <_description>KDE Office applications</_description>

+     <_description>Office software maintained by KDE</_description>

      <default>false</default>

-     <uservisible>false</uservisible>

+     <uservisible>true</uservisible>

      <packagelist>

-       <packagereq>calligra-sheets</packagereq>

-       <packagereq>calligra-stage</packagereq>

-       <packagereq>calligra-words</packagereq>

-       <packagereq>okular</packagereq>

+       <packagereq type="default">calligra</packagereq>

+       <packagereq type="optional">calligra-core</packagereq>

+       <packagereq type="optional">calligra-karbon</packagereq>

+       <packagereq type="optional">calligra-l10n</packagereq>

+       <packagereq type="optional">calligra-okular-odpgenerator</packagereq>

+       <packagereq type="optional">calligra-okular-odtgenerator</packagereq>

+       <packagereq type="default">calligra-plan </packagereq>

+       <packagereq type="default">calligra-sheets </packagereq>

+       <packagereq type="default">calligra-stage </packagereq>

+       <packagereq type="default">calligra-words</packagereq>

+       <packagereq type="optional">calligraplan</packagereq>

+       <packagereq type="default">kaddressbook</packagereq>

+       <packagereq type="optional">kexi</packagereq>

+       <packagereq type="optional">kexi-spreadsheet-import</packagereq>

      </packagelist>

    </group>

    <group>

-     <id>kde-software-development</id>

-     <_name>KDE Software Development</_name>

-     <_description>Install these packages to develop Qt and KDE graphical applications.</_description>

+     <id>kde-system</id>

+     <_name>KDE System</_name>

+     <_description>System tools maintained by KDE</_description>

      <default>false</default>

-     <uservisible>false</uservisible>

+     <uservisible>true</uservisible>

      <packagelist>

-       <packagereq type="mandatory">cmake</packagereq>

-       <packagereq type="mandatory">kdelibs-devel</packagereq>

-       <packagereq type="mandatory">qt-devel</packagereq>

-       <packagereq type="default">cervisia</packagereq>

-       <packagereq type="default">dolphin-plugins</packagereq>

-       <packagereq type="default">kapptemplate</packagereq>

+       <packagereq type="optional">apper</packagereq>

+       <packagereq type="optional">apper-updater</packagereq>

+       <packagereq type="default">dolphin</packagereq>

+       <packagereq type="optional">dolphin-devel</packagereq>

+       <packagereq type="optional">dolphin-plugins</packagereq>

+       <packagereq type="default">filelight</packagereq>

+       <packagereq type="optional">kde-partitionmanager</packagereq>

+       <packagereq type="default">kdesu</packagereq>

+       <packagereq type="optional">kdf</packagereq>

+       <packagereq type="default">konsole5</packagereq>

+       <packagereq type="optional">konsole5-part</packagereq>

+       <packagereq type="default">ksystemlog</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-utilities</id>

+     <_name>KDE Utilities</_name>

+     <_description>Utilities maintained by KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="default">ark</packagereq>

+       <packagereq type="optional">isoimagewriter</packagereq>

+       <packagereq type="optional">kalarm</packagereq>

        <packagereq type="default">kate</packagereq>

-       <packagereq type="default">kcachegrind</packagereq>

-       <packagereq type="default">kde-dev-scripts</packagereq>

-       <packagereq type="default">kdelibs-webkit-devel</packagereq>

-       <packagereq type="default">kdepimlibs-devel</packagereq>

-       <packagereq type="default">kdesdk-kioslaves</packagereq>

-       <packagereq type="default">kdesdk-thumbnailers</packagereq>

-       <packagereq type="default">kdevelop</packagereq>

-       <packagereq type="default">kompare</packagereq>

-       <packagereq type="default">kpartloader</packagereq>

-       <packagereq type="default">kuiviewer</packagereq>

-       <packagereq type="default">okteta</packagereq>

-       <packagereq type="default">poxml</packagereq>

-       <packagereq type="default">umbrello</packagereq>

+       <packagereq type="default">kate-plugins</packagereq>

+       <packagereq type="optional">kcalc</packagereq>

+       <packagereq type="optional">kcharselect</packagereq>

+       <packagereq type="optional">kcolorchooser</packagereq>

+       <packagereq type="optional">kcoloredit</packagereq>

+       <packagereq type="optional">kcron</packagereq>

+       <packagereq type="default">kde-cli-tools</packagereq>

+       <packagereq type="optional">kde-print-manager</packagereq>

+       <packagereq type="optional">kdebugsettings</packagereq>

+       <packagereq type="default">kdialog</packagereq>

+       <packagereq type="optional">keditbookmarks</packagereq>

+       <packagereq type="optional">kfloppy</packagereq>

+       <packagereq type="optional">kmag</packagereq>

+       <packagereq type="optional">kmenuedit</packagereq>

+       <packagereq type="optional">kmousetool</packagereq>

+       <packagereq type="optional">kpartloader</packagereq>

+       <packagereq type="optional">krusader</packagereq>

+       <packagereq type="optional">kteatime</packagereq>

+       <packagereq type="optional">ktimer</packagereq>

+       <packagereq type="default">yakuake</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-fedora-branding</id>

+     <_name>Fedora KDE Branding</_name>

+     <_description>Fedora branding for KDE software</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">kde-settings-plasma</packagereq>

+       <packagereq type="optional">kde-settings-pulseaudio</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-frameworks</id>

+     <_name>KDE Frameworks 5</_name>

+     <_description>The KDE Frameworks</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">analitza</packagereq>

+       <packagereq type="optional">analitza-devel</packagereq>

+       <packagereq type="optional">attica</packagereq>

+       <packagereq type="optional">attica-devel</packagereq>

+       <packagereq type="optional">baloo</packagereq>

+       <packagereq type="optional">baloo-akonadi</packagereq>

+       <packagereq type="optional">baloo-devel</packagereq>

+       <packagereq type="optional">baloo-file</packagereq>

+       <packagereq type="optional">baloo-widgets</packagereq>

+       <packagereq type="optional">baloo-widgets-devel</packagereq>

+       <packagereq type="optional">extra-cmake-modules</packagereq>

+       <packagereq type="optional">grantlee-editor</packagereq>

+       <packagereq type="optional">kaccounts-integration</packagereq>

+       <packagereq type="optional">kaccounts-integration-devel</packagereq>

+       <packagereq type="optional">kaccounts-providers</packagereq>

+       <packagereq type="optional">kactivities</packagereq>

+       <packagereq type="optional">kactivities-devel</packagereq>

+       <packagereq type="optional">kactivities-nepomuk</packagereq>

+       <packagereq type="optional">kactivities-nepomuk-devel</packagereq>

+       <packagereq type="optional">kactivitymanagerd</packagereq>

+       <packagereq type="optional">kdb</packagereq>

+       <packagereq type="optional">kdb-devel</packagereq>

+       <packagereq type="optional">kdb-driver-mysql</packagereq>

+       <packagereq type="optional">kdb-driver-postgresql</packagereq>

+       <packagereq type="optional">kdecoration</packagereq>

+       <packagereq type="optional">kdecoration-devel</packagereq>

+       <packagereq type="optional">kdnssd</packagereq>

+       <packagereq type="optional">kf5-akonadi-calendar</packagereq>

+       <packagereq type="optional">kf5-akonadi-calendar-devel</packagereq>

+       <packagereq type="optional">kf5-akonadi-contacts</packagereq>

+       <packagereq type="optional">kf5-akonadi-contacts-devel</packagereq>

+       <packagereq type="optional">kf5-akonadi-mime</packagereq>

+       <packagereq type="optional">kf5-akonadi-mime-devel</packagereq>

+       <packagereq type="optional">kf5-akonadi-notes</packagereq>

+       <packagereq type="optional">kf5-akonadi-notes-devel</packagereq>

+       <packagereq type="optional">kf5-akonadi-search</packagereq>

+       <packagereq type="optional">kf5-akonadi-search-devel</packagereq>

+       <packagereq type="optional">kf5-akonadi-server</packagereq>

+       <packagereq type="optional">kf5-akonadi-server-devel</packagereq>

+       <packagereq type="optional">kf5-akonadi-server-mysql</packagereq>

+       <packagereq type="optional">kf5-attica</packagereq>

+       <packagereq type="optional">kf5-attica-devel</packagereq>

+       <packagereq type="optional">kf5-audiocd-kio</packagereq>

+       <packagereq type="optional">kf5-audiocd-kio-devel</packagereq>

+       <packagereq type="optional">kf5-audiocd-kio-doc</packagereq>

+       <packagereq type="optional">kf5-baloo</packagereq>

+       <packagereq type="optional">kf5-baloo-devel</packagereq>

+       <packagereq type="optional">kf5-baloo-file</packagereq>

+       <packagereq type="optional">kf5-bluez-qt</packagereq>

+       <packagereq type="optional">kf5-bluez-qt-devel</packagereq>

+       <packagereq type="optional">kf5-calendarsupport</packagereq>

+       <packagereq type="optional">kf5-calendarsupport-devel</packagereq>

+       <packagereq type="optional">kf5-eventviews</packagereq>

+       <packagereq type="optional">kf5-eventviews-devel</packagereq>

+       <packagereq type="optional">kf5-frameworkintegration</packagereq>

+       <packagereq type="optional">kf5-frameworkintegration-devel</packagereq>

+       <packagereq type="optional">kf5-gpgmepp</packagereq>

+       <packagereq type="optional">kf5-gpgmepp-devel</packagereq>

+       <packagereq type="optional">kf5-grantleetheme</packagereq>

+       <packagereq type="optional">kf5-grantleetheme-devel</packagereq>

+       <packagereq type="optional">kf5-incidenceeditor</packagereq>

+       <packagereq type="optional">kf5-incidenceeditor-devel</packagereq>

+       <packagereq type="optional">kf5-kactivities</packagereq>

+       <packagereq type="optional">kf5-kactivities-devel</packagereq>

+       <packagereq type="optional">kf5-kactivities-stats</packagereq>

+       <packagereq type="optional">kf5-kactivities-stats-devel</packagereq>

+       <packagereq type="optional">kf5-kalarmcal</packagereq>

+       <packagereq type="optional">kf5-kalarmcal-devel</packagereq>

+       <packagereq type="optional">kf5-kapidox</packagereq>

+       <packagereq type="optional">kf5-karchive</packagereq>

+       <packagereq type="optional">kf5-karchive-devel</packagereq>

+       <packagereq type="optional">kf5-kauth</packagereq>

+       <packagereq type="optional">kf5-kauth-devel</packagereq>

+       <packagereq type="optional">kf5-kblog</packagereq>

+       <packagereq type="optional">kf5-kblog-devel</packagereq>

+       <packagereq type="optional">kf5-kbookmarks</packagereq>

+       <packagereq type="optional">kf5-kbookmarks-devel</packagereq>

+       <packagereq type="optional">kf5-kcalendarcore</packagereq>

+       <packagereq type="optional">kf5-kcalendarcore-devel</packagereq>

+       <packagereq type="optional">kf5-kcalendarutils</packagereq>

+       <packagereq type="optional">kf5-kcalendarutils-devel</packagereq>

+       <packagereq type="optional">kf5-kcmutils</packagereq>

+       <packagereq type="optional">kf5-kcmutils-devel</packagereq>

+       <packagereq type="optional">kf5-kcodecs</packagereq>

+       <packagereq type="optional">kf5-kcodecs-devel</packagereq>

+       <packagereq type="optional">kf5-kcompletion</packagereq>

+       <packagereq type="optional">kf5-kcompletion-devel</packagereq>

+       <packagereq type="optional">kf5-kconfig</packagereq>

+       <packagereq type="optional">kf5-kconfig-core</packagereq>

+       <packagereq type="optional">kf5-kconfig-devel</packagereq>

+       <packagereq type="optional">kf5-kconfig-gui</packagereq>

+       <packagereq type="optional">kf5-kconfigwidgets</packagereq>

+       <packagereq type="optional">kf5-kconfigwidgets-devel</packagereq>

+       <packagereq type="optional">kf5-kcontacts</packagereq>

+       <packagereq type="optional">kf5-kcontacts-devel</packagereq>

+       <packagereq type="optional">kf5-kcoreaddons</packagereq>

+       <packagereq type="optional">kf5-kcoreaddons-devel</packagereq>

+       <packagereq type="optional">kf5-kcrash</packagereq>

+       <packagereq type="optional">kf5-kcrash-devel</packagereq>

+       <packagereq type="optional">kf5-kdav</packagereq>

+       <packagereq type="optional">kf5-kdav-devel</packagereq>

+       <packagereq type="optional">kf5-kdbusaddons</packagereq>

+       <packagereq type="optional">kf5-kdbusaddons-devel</packagereq>

+       <packagereq type="optional">kf5-kdeclarative</packagereq>

+       <packagereq type="optional">kf5-kdeclarative-devel</packagereq>

+       <packagereq type="optional">kf5-kded</packagereq>

+       <packagereq type="optional">kf5-kded-devel</packagereq>

+       <packagereq type="optional">kf5-kdelibs4support</packagereq>

+       <packagereq type="optional">kf5-kdelibs4support-devel</packagereq>

+       <packagereq type="optional">kf5-kdelibs4support-doc</packagereq>

+       <packagereq type="optional">kf5-kdesignerplugin</packagereq>

+       <packagereq type="optional">kf5-kdesu</packagereq>

+       <packagereq type="optional">kf5-kdesu-devel</packagereq>

+       <packagereq type="optional">kf5-kdewebkit</packagereq>

+       <packagereq type="optional">kf5-kdewebkit-devel</packagereq>

+       <packagereq type="optional">kf5-kdgantt2</packagereq>

+       <packagereq type="optional">kf5-kdgantt2-devel</packagereq>

+       <packagereq type="optional">kf5-kdnssd</packagereq>

+       <packagereq type="optional">kf5-kdnssd-devel</packagereq>

+       <packagereq type="optional">kf5-kdoctools</packagereq>

+       <packagereq type="optional">kf5-kdoctools-devel</packagereq>

+       <packagereq type="optional">kf5-kemoticons</packagereq>

+       <packagereq type="optional">kf5-kemoticons-devel</packagereq>

+       <packagereq type="optional">kf5-kfilemetadata</packagereq>

+       <packagereq type="optional">kf5-kfilemetadata-devel</packagereq>

+       <packagereq type="optional">kf5-kglobalaccel</packagereq>

+       <packagereq type="optional">kf5-kglobalaccel-devel</packagereq>

+       <packagereq type="optional">kf5-kguiaddons</packagereq>

+       <packagereq type="optional">kf5-kguiaddons-devel</packagereq>

+       <packagereq type="optional">kf5-kholidays</packagereq>

+       <packagereq type="optional">kf5-kholidays-devel</packagereq>

+       <packagereq type="optional">kf5-khtml</packagereq>

+       <packagereq type="optional">kf5-khtml-devel</packagereq>

+       <packagereq type="optional">kf5-ki18n</packagereq>

+       <packagereq type="optional">kf5-ki18n-devel</packagereq>

+       <packagereq type="optional">kf5-kiconthemes</packagereq>

+       <packagereq type="optional">kf5-kiconthemes-devel</packagereq>

+       <packagereq type="optional">kf5-kidentitymanagement</packagereq>

+       <packagereq type="optional">kf5-kidentitymanagement-devel</packagereq>

+       <packagereq type="optional">kf5-kidletime</packagereq>

+       <packagereq type="optional">kf5-kidletime-devel</packagereq>

+       <packagereq type="optional">kf5-kimageformats</packagereq>

+       <packagereq type="optional">kf5-kimap</packagereq>

+       <packagereq type="optional">kf5-kimap-devel</packagereq>

+       <packagereq type="optional">kf5-kinit</packagereq>

+       <packagereq type="optional">kf5-kinit-devel</packagereq>

+       <packagereq type="optional">kf5-kio</packagereq>

+       <packagereq type="optional">kf5-kio-core</packagereq>

+       <packagereq type="optional">kf5-kio-devel</packagereq>

+       <packagereq type="optional">kf5-kio-doc</packagereq>

+       <packagereq type="optional">kf5-kio-file-widgets</packagereq>

+       <packagereq type="optional">kf5-kio-gui</packagereq>

+       <packagereq type="optional">kf5-kio-ntlm</packagereq>

+       <packagereq type="optional">kf5-kio-widgets</packagereq>

+       <packagereq type="optional">kf5-kipi-plugins</packagereq>

+       <packagereq type="optional">kf5-kirigami</packagereq>

+       <packagereq type="optional">kf5-kirigami-devel</packagereq>

+       <packagereq type="optional">kf5-kirigami2</packagereq>

+       <packagereq type="optional">kf5-kirigami2-devel</packagereq>

+       <packagereq type="optional">kf5-kitemmodels</packagereq>

+       <packagereq type="optional">kf5-kitemmodels-devel</packagereq>

+       <packagereq type="optional">kf5-kitemviews</packagereq>

+       <packagereq type="optional">kf5-kitemviews-devel</packagereq>

+       <packagereq type="optional">kf5-kitinerary</packagereq>

+       <packagereq type="optional">kf5-kitinerary-devel</packagereq>

+       <packagereq type="optional">kf5-kjobwidgets</packagereq>

+       <packagereq type="optional">kf5-kjobwidgets-devel</packagereq>

+       <packagereq type="optional">kf5-kjs</packagereq>

+       <packagereq type="optional">kf5-kjs-devel</packagereq>

+       <packagereq type="optional">kf5-kjsembed</packagereq>

+       <packagereq type="optional">kf5-kjsembed-devel</packagereq>

+       <packagereq type="optional">kf5-kldap</packagereq>

+       <packagereq type="optional">kf5-kldap-devel</packagereq>

+       <packagereq type="optional">kf5-kmailtransport</packagereq>

+       <packagereq type="optional">kf5-kmailtransport-akonadi</packagereq>

+       <packagereq type="optional">kf5-kmailtransport-devel</packagereq>

+       <packagereq type="optional">kf5-kmbox</packagereq>

+       <packagereq type="optional">kf5-kmbox-devel</packagereq>

+       <packagereq type="optional">kf5-kmediaplayer</packagereq>

+       <packagereq type="optional">kf5-kmediaplayer-devel</packagereq>

+       <packagereq type="optional">kf5-kmime</packagereq>

+       <packagereq type="optional">kf5-kmime-devel</packagereq>

+       <packagereq type="optional">kf5-knewstuff</packagereq>

+       <packagereq type="optional">kf5-knewstuff-devel</packagereq>

+       <packagereq type="optional">kf5-knotifications</packagereq>

+       <packagereq type="optional">kf5-knotifications-devel</packagereq>

+       <packagereq type="optional">kf5-knotifyconfig</packagereq>

+       <packagereq type="optional">kf5-knotifyconfig-devel</packagereq>

+       <packagereq type="optional">kf5-kontactinterface</packagereq>

+       <packagereq type="optional">kf5-kontactinterface-devel</packagereq>

+       <packagereq type="optional">kf5-kpackage</packagereq>

+       <packagereq type="optional">kf5-kpackage-devel</packagereq>

+       <packagereq type="optional">kf5-kparts</packagereq>

+       <packagereq type="optional">kf5-kparts-devel</packagereq>

+       <packagereq type="optional">kf5-kpeople</packagereq>

+       <packagereq type="optional">kf5-kpeople-devel</packagereq>

+       <packagereq type="optional">kf5-kpimtextedit</packagereq>

+       <packagereq type="optional">kf5-kpimtextedit-devel</packagereq>

+       <packagereq type="optional">kf5-kpkpass</packagereq>

+       <packagereq type="optional">kf5-kpkpass-devel</packagereq>

+       <packagereq type="optional">kf5-kplotting</packagereq>

+       <packagereq type="optional">kf5-kplotting-devel</packagereq>

+       <packagereq type="optional">kf5-kpty</packagereq>

+       <packagereq type="optional">kf5-kpty-devel</packagereq>

+       <packagereq type="optional">kf5-kquickcharts</packagereq>

+       <packagereq type="optional">kf5-kquickcharts-devel</packagereq>

+       <packagereq type="optional">kf5-kross</packagereq>

+       <packagereq type="optional">kf5-kross-core</packagereq>

+       <packagereq type="optional">kf5-kross-devel</packagereq>

+       <packagereq type="optional">kf5-kross-interpreters</packagereq>

+       <packagereq type="optional">kf5-kross-java</packagereq>

+       <packagereq type="optional">kf5-kross-python2</packagereq>

+       <packagereq type="optional">kf5-kross-ruby</packagereq>

+       <packagereq type="optional">kf5-kross-ui</packagereq>

+       <packagereq type="optional">kf5-krunner</packagereq>

+       <packagereq type="optional">kf5-krunner-devel</packagereq>

+       <packagereq type="optional">kf5-kservice</packagereq>

+       <packagereq type="optional">kf5-kservice-devel</packagereq>

+       <packagereq type="optional">kf5-ksmtp</packagereq>

+       <packagereq type="optional">kf5-ksmtp-devel</packagereq>

+       <packagereq type="optional">kf5-ktexteditor</packagereq>

+       <packagereq type="optional">kf5-ktexteditor-devel</packagereq>

+       <packagereq type="optional">kf5-ktextwidgets</packagereq>

+       <packagereq type="optional">kf5-ktextwidgets-devel</packagereq>

+       <packagereq type="optional">kf5-ktnef</packagereq>

+       <packagereq type="optional">kf5-ktnef-devel</packagereq>

+       <packagereq type="optional">kf5-kunitconversion</packagereq>

+       <packagereq type="optional">kf5-kunitconversion-devel</packagereq>

+       <packagereq type="optional">kf5-kwallet</packagereq>

+       <packagereq type="optional">kf5-kwallet-devel</packagereq>

+       <packagereq type="optional">kf5-kwayland</packagereq>

+       <packagereq type="optional">kf5-kwayland-devel</packagereq>

+       <packagereq type="optional">kf5-kwidgetsaddons</packagereq>

+       <packagereq type="optional">kf5-kwidgetsaddons-devel</packagereq>

+       <packagereq type="optional">kf5-kwindowsystem</packagereq>

+       <packagereq type="optional">kf5-kwindowsystem-devel</packagereq>

+       <packagereq type="optional">kf5-kxmlgui</packagereq>

+       <packagereq type="optional">kf5-kxmlgui-devel</packagereq>

+       <packagereq type="optional">kf5-kxmlrpcclient</packagereq>

+       <packagereq type="optional">kf5-kxmlrpcclient-devel</packagereq>

+       <packagereq type="optional">kf5-libgravatar</packagereq>

+       <packagereq type="optional">kf5-libgravatar-devel</packagereq>

+       <packagereq type="optional">kf5-libkcddb</packagereq>

+       <packagereq type="optional">kf5-libkcddb-devel</packagereq>

+       <packagereq type="optional">kf5-libkcddb-doc</packagereq>

+       <packagereq type="optional">kf5-libkcompactdisc</packagereq>

+       <packagereq type="optional">kf5-libkcompactdisc-devel</packagereq>

+       <packagereq type="optional">kf5-libkdcraw</packagereq>

+       <packagereq type="optional">kf5-libkdcraw-devel</packagereq>

+       <packagereq type="optional">kf5-libkdepim</packagereq>

+       <packagereq type="optional">kf5-libkdepim-akonadi</packagereq>

+       <packagereq type="optional">kf5-libkdepim-devel</packagereq>

+       <packagereq type="optional">kf5-libkexiv2</packagereq>

+       <packagereq type="optional">kf5-libkexiv2-devel</packagereq>

+       <packagereq type="optional">kf5-libkgeomap</packagereq>

+       <packagereq type="optional">kf5-libkgeomap-devel</packagereq>

+       <packagereq type="optional">kf5-libkipi</packagereq>

+       <packagereq type="optional">kf5-libkipi-devel</packagereq>

+       <packagereq type="optional">kf5-libkleo</packagereq>

+       <packagereq type="optional">kf5-libkleo-devel</packagereq>

+       <packagereq type="optional">kf5-libksane</packagereq>

+       <packagereq type="optional">kf5-libksane-devel</packagereq>

+       <packagereq type="optional">kf5-libksieve</packagereq>

+       <packagereq type="optional">kf5-libksieve-devel</packagereq>

+       <packagereq type="optional">kf5-libktorrent</packagereq>

+       <packagereq type="optional">kf5-libktorrent-devel</packagereq>

+       <packagereq type="optional">kf5-mailcommon</packagereq>

+       <packagereq type="optional">kf5-mailcommon-devel</packagereq>

+       <packagereq type="optional">kf5-mailimporter</packagereq>

+       <packagereq type="optional">kf5-mailimporter-akonadi</packagereq>

+       <packagereq type="optional">kf5-mailimporter-devel</packagereq>

+       <packagereq type="optional">kf5-messagelib</packagereq>

+       <packagereq type="optional">kf5-messagelib-devel</packagereq>

+       <packagereq type="optional">kf5-modemmanager-qt</packagereq>

+       <packagereq type="optional">kf5-modemmanager-qt-devel</packagereq>

+       <packagereq type="optional">kf5-networkmanager-qt</packagereq>

+       <packagereq type="optional">kf5-networkmanager-qt-devel</packagereq>

+       <packagereq type="optional">kf5-pimcommon</packagereq>

+       <packagereq type="optional">kf5-pimcommon-akonadi</packagereq>

+       <packagereq type="optional">kf5-pimcommon-devel</packagereq>

+       <packagereq type="optional">kf5-plasma</packagereq>

+       <packagereq type="optional">kf5-plasma-devel</packagereq>

+       <packagereq type="optional">kf5-prison</packagereq>

+       <packagereq type="optional">kf5-prison-devel</packagereq>

+       <packagereq type="optional">kf5-purpose</packagereq>

+       <packagereq type="optional">kf5-purpose-devel</packagereq>

+       <packagereq type="optional">kf5-solid</packagereq>

+       <packagereq type="optional">kf5-solid-devel</packagereq>

+       <packagereq type="optional">kf5-sonnet</packagereq>

+       <packagereq type="optional">kf5-sonnet-core</packagereq>

+       <packagereq type="optional">kf5-sonnet-devel</packagereq>

+       <packagereq type="optional">kf5-sonnet-ui</packagereq>

+       <packagereq type="optional">kf5-syndication</packagereq>

+       <packagereq type="optional">kf5-syndication-devel</packagereq>

+       <packagereq type="optional">kf5-syntax-highlighting</packagereq>

+       <packagereq type="optional">kf5-syntax-highlighting-devel</packagereq>

+       <packagereq type="optional">kf5-threadweaver</packagereq>

+       <packagereq type="optional">kf5-threadweaver-devel</packagereq>

+       <packagereq type="optional">kqtquickcharts</packagereq>

+       <packagereq type="optional">ksaneplugin</packagereq>

+       <packagereq type="optional">kwallet</packagereq>

+       <packagereq type="optional">kwalletmanager5</packagereq>

+       <packagereq type="optional">prison</packagereq>

+       <packagereq type="optional">prison-devel</packagereq>

+       <packagereq type="optional">prison-qt5</packagereq>

+       <packagereq type="optional">prison-qt5-devel</packagereq>

+       <packagereq type="optional">pulseaudio-qt</packagereq>

+       <packagereq type="optional">pulseaudio-qt-devel</packagereq>

+       <packagereq type="optional">qaccessibilityclient</packagereq>

+       <packagereq type="optional">qaccessibilityclient-devel</packagereq>

+       <packagereq type="optional">svgpart</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-i18n</id>

+     <_name>KDE Language Packs</_name>

+     <_description>Language packs for KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">kde-i18n</packagereq>

+       <packagereq type="optional">kde-i18n-Afrikaans</packagereq>

+       <packagereq type="optional">kde-i18n-Arabic </packagereq>

+       <packagereq type="optional">kde-i18n-Azerbaijani</packagereq>

+       <packagereq type="optional">kde-i18n-Basque</packagereq>

+       <packagereq type="optional">kde-i18n-Belarusian</packagereq>

+       <packagereq type="optional">kde-i18n-Bengali</packagereq>

+       <packagereq type="optional">kde-i18n-Bosnian</packagereq>

+       <packagereq type="optional">kde-i18n-Brazil</packagereq>

+       <packagereq type="optional">kde-i18n-Breton</packagereq>

+       <packagereq type="optional">kde-i18n-British</packagereq>

+       <packagereq type="optional">kde-i18n-Bulgarian</packagereq>

+       <packagereq type="optional">kde-i18n-Catalan</packagereq>

+       <packagereq type="optional">kde-i18n-Chinese</packagereq>

+       <packagereq type="optional">kde-i18n-Chinese-Big5</packagereq>

+       <packagereq type="optional">kde-i18n-Croatian</packagereq>

+       <packagereq type="optional">kde-i18n-Cymraeg</packagereq>

+       <packagereq type="optional">kde-i18n-Czech</packagereq>

+       <packagereq type="optional">kde-i18n-Danish</packagereq>

+       <packagereq type="optional">kde-i18n-Dutch</packagereq>

+       <packagereq type="optional">kde-i18n-Esperanto</packagereq>

+       <packagereq type="optional">kde-i18n-Estonian</packagereq>

+       <packagereq type="optional">kde-i18n-Faroese</packagereq>

+       <packagereq type="optional">kde-i18n-Farsi</packagereq>

+       <packagereq type="optional">kde-i18n-Finnish</packagereq>

+       <packagereq type="optional">kde-i18n-flags</packagereq>

+       <packagereq type="optional">kde-i18n-French</packagereq>

+       <packagereq type="optional">kde-i18n-Frisian</packagereq>

+       <packagereq type="optional">kde-i18n-Galician</packagereq>

+       <packagereq type="optional">kde-i18n-German</packagereq>

+       <packagereq type="optional">kde-i18n-Greek</packagereq>

+       <packagereq type="optional">kde-i18n-Hebrew</packagereq>

+       <packagereq type="optional">kde-i18n-Hindi</packagereq>

+       <packagereq type="optional">kde-i18n-Hungarian</packagereq>

+       <packagereq type="optional">kde-i18n-Icelandic</packagereq>

+       <packagereq type="optional">kde-i18n-Indonesian</packagereq>

+       <packagereq type="optional">kde-i18n-Irish</packagereq>

+       <packagereq type="optional">kde-i18n-Italian</packagereq>

+       <packagereq type="optional">kde-i18n-Japanese</packagereq>

+       <packagereq type="optional">kde-i18n-Korean</packagereq>

+       <packagereq type="optional">kde-i18n-Kurdish</packagereq>

+       <packagereq type="optional">kde-i18n-Lao</packagereq>

+       <packagereq type="optional">kde-i18n-Latvian</packagereq>

+       <packagereq type="optional">kde-i18n-Lithuanian</packagereq>

+       <packagereq type="optional">kde-i18n-Macedonian</packagereq>

+       <packagereq type="optional">kde-i18n-Maltese</packagereq>

+       <packagereq type="optional">kde-i18n-Maori</packagereq>

+       <packagereq type="optional">kde-i18n-Norwegian</packagereq>

+       <packagereq type="optional">kde-i18n-Norwegian-Nynorsk</packagereq>

+       <packagereq type="optional">kde-i18n-Occitan</packagereq>

+       <packagereq type="optional">kde-i18n-Polish</packagereq>

+       <packagereq type="optional">kde-i18n-Portuguese</packagereq>

+       <packagereq type="optional">kde-i18n-Punjabi</packagereq>

+       <packagereq type="optional">kde-i18n-Romanian</packagereq>

+       <packagereq type="optional">kde-i18n-Russian</packagereq>

+       <packagereq type="optional">kde-i18n-Serbian</packagereq>

+       <packagereq type="optional">kde-i18n-Slovak</packagereq>

+       <packagereq type="optional">kde-i18n-Slovenian</packagereq>

+       <packagereq type="optional">kde-i18n-Spanish</packagereq>

+       <packagereq type="optional">kde-i18n-Swedish</packagereq>

+       <packagereq type="optional">kde-i18n-Tajik</packagereq>

+       <packagereq type="optional">kde-i18n-Tamil</packagereq>

+       <packagereq type="optional">kde-i18n-Thai</packagereq>

+       <packagereq type="optional">kde-i18n-Tibetan</packagereq>

+       <packagereq type="optional">kde-i18n-Turkish</packagereq>

+       <packagereq type="optional">kde-i18n-Ukrainian</packagereq>

+       <packagereq type="optional">kde-i18n-Venda</packagereq>

+       <packagereq type="optional">kde-i18n-Vietnamese</packagereq>

+       <packagereq type="optional">kde-i18n-Walloon</packagereq>

+       <packagereq type="optional">kde-i18n-Welsh</packagereq>

+       <packagereq type="optional">kde-i18n-Xhosa</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-kcms</id>

+     <_name>KDE Config Modules</_name>

+     <_description>Extra configuration modules for KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="default">kcm_colors</packagereq>

+       <packagereq type="default">kcm_systemd</packagereq>

+       <packagereq type="default">kcm_wacomtablet</packagereq>

+       <packagereq type="default">kcm-qt-graphicssystem</packagereq>

+       <packagereq type="default">kde-gtk-config</packagereq>

+       <packagereq type="default">sddm-kcm</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-kio-extensions</id>

+     <_name>KDE I/O Extensions</_name>

+     <_description>Extensions to KDE's KIO</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">audiocd-kio</packagereq>

        <packagereq type="optional">audiocd-kio-devel</packagereq>

-       <packagereq type="optional">cantor-devel</packagereq>

-       <packagereq type="optional">gambas3-runtime</packagereq>

-       <packagereq type="optional">kdbg</packagereq>

-       <packagereq type="optional">kdelibs3-devel</packagereq>

-       <packagereq type="optional">kdesvn</packagereq>

-       <packagereq type="optional">kdewebdev-devel</packagereq>

-       <packagereq type="optional">kiten-devel</packagereq>

-       <packagereq type="optional">krazy2</packagereq>

-       <packagereq type="optional">ktp-common-internals-devel</packagereq>

+       <packagereq type="optional">audiocd-kio-doc</packagereq>

+       <packagereq type="optional">kio_gopher</packagereq>

+       <packagereq type="optional">kio-extras</packagereq>

+       <packagereq type="optional">kio-extras-devel</packagereq>

+       <packagereq type="optional">kio-extras-info</packagereq>

+       <packagereq type="optional">kio-gdrive</packagereq>

+       <packagereq type="optional">kio-upnp-ms</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-l10n</id>

+     <_name>KDE Localization Packs</_name>

+     <_description>Localization packs for KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">kde-l10n</packagereq>

+       <packagereq type="optional">kde-l10n-af</packagereq>

+       <packagereq type="optional">kde-l10n-ar</packagereq>

+       <packagereq type="optional">kde-l10n-ast</packagereq>

+       <packagereq type="optional">kde-l10n-az</packagereq>

+       <packagereq type="optional">kde-l10n-be</packagereq>

+       <packagereq type="optional">kde-l10n-bg</packagereq>

+       <packagereq type="optional">kde-l10n-bn_IN</packagereq>

+       <packagereq type="optional">kde-l10n-bo</packagereq>

+       <packagereq type="optional">kde-l10n-br</packagereq>

+       <packagereq type="optional">kde-l10n-bs</packagereq>

+       <packagereq type="optional">kde-l10n-ca</packagereq>

+       <packagereq type="optional">kde-l10n-ca-valencia</packagereq>

+       <packagereq type="optional">kde-l10n-cs</packagereq>

+       <packagereq type="optional">kde-l10n-csb</packagereq>

+       <packagereq type="optional">kde-l10n-cy</packagereq>

+       <packagereq type="optional">kde-l10n-da</packagereq>

+       <packagereq type="optional">kde-l10n-de</packagereq>

+       <packagereq type="optional">kde-l10n-el</packagereq>

+       <packagereq type="optional">kde-l10n-en_GB</packagereq>

+       <packagereq type="optional">kde-l10n-eo</packagereq>

+       <packagereq type="optional">kde-l10n-es</packagereq>

+       <packagereq type="optional">kde-l10n-et</packagereq>

+       <packagereq type="optional">kde-l10n-eu</packagereq>

+       <packagereq type="optional">kde-l10n-fa</packagereq>

+       <packagereq type="optional">kde-l10n-fi</packagereq>

+       <packagereq type="optional">kde-l10n-fo</packagereq>

+       <packagereq type="optional">kde-l10n-fr</packagereq>

+       <packagereq type="optional">kde-l10n-fy</packagereq>

+       <packagereq type="optional">kde-l10n-ga</packagereq>

+       <packagereq type="optional">kde-l10n-gl</packagereq>

+       <packagereq type="optional">kde-l10n-gu</packagereq>

+       <packagereq type="optional">kde-l10n-he</packagereq>

+       <packagereq type="optional">kde-l10n-hi</packagereq>

+       <packagereq type="optional">kde-l10n-hne</packagereq>

+       <packagereq type="optional">kde-l10n-hr</packagereq>

+       <packagereq type="optional">kde-l10n-hu</packagereq>

+       <packagereq type="optional">kde-l10n-ia</packagereq>

+       <packagereq type="optional">kde-l10n-id</packagereq>

+       <packagereq type="optional">kde-l10n-is</packagereq>

+       <packagereq type="optional">kde-l10n-it</packagereq>

+       <packagereq type="optional">kde-l10n-ja</packagereq>

+       <packagereq type="optional">kde-l10n-kk</packagereq>

+       <packagereq type="optional">kde-l10n-km</packagereq>

+       <packagereq type="optional">kde-l10n-kn</packagereq>

+       <packagereq type="optional">kde-l10n-ko</packagereq>

+       <packagereq type="optional">kde-l10n-ku</packagereq>

+       <packagereq type="optional">kde-l10n-lo</packagereq>

+       <packagereq type="optional">kde-l10n-lt</packagereq>

+       <packagereq type="optional">kde-l10n-lv</packagereq>

+       <packagereq type="optional">kde-l10n-mai</packagereq>

+       <packagereq type="optional">kde-l10n-mi</packagereq>

+       <packagereq type="optional">kde-l10n-mk</packagereq>

+       <packagereq type="optional">kde-l10n-ml</packagereq>

+       <packagereq type="optional">kde-l10n-mr</packagereq>

+       <packagereq type="optional">kde-l10n-mt</packagereq>

+       <packagereq type="optional">kde-l10n-nb</packagereq>

+       <packagereq type="optional">kde-l10n-nds</packagereq>

+       <packagereq type="optional">kde-l10n-ne</packagereq>

+       <packagereq type="optional">kde-l10n-nl</packagereq>

+       <packagereq type="optional">kde-l10n-nn</packagereq>

+       <packagereq type="optional">kde-l10n-oc</packagereq>

+       <packagereq type="optional">kde-l10n-pa</packagereq>

+       <packagereq type="optional">kde-l10n-pl</packagereq>

+       <packagereq type="optional">kde-l10n-pt</packagereq>

+       <packagereq type="optional">kde-l10n-pt_BR</packagereq>

+       <packagereq type="optional">kde-l10n-ro</packagereq>

+       <packagereq type="optional">kde-l10n-ru</packagereq>

+       <packagereq type="optional">kde-l10n-se</packagereq>

+       <packagereq type="optional">kde-l10n-si</packagereq>

+       <packagereq type="optional">kde-l10n-sk</packagereq>

+       <packagereq type="optional">kde-l10n-sl</packagereq>

+       <packagereq type="optional">kde-l10n-sr</packagereq>

+       <packagereq type="optional">kde-l10n-sv</packagereq>

+       <packagereq type="optional">kde-l10n-ta</packagereq>

+       <packagereq type="optional">kde-l10n-tg</packagereq>

+       <packagereq type="optional">kde-l10n-th</packagereq>

+       <packagereq type="optional">kde-l10n-tr</packagereq>

+       <packagereq type="optional">kde-l10n-ug</packagereq>

+       <packagereq type="optional">kde-l10n-uk</packagereq>

+       <packagereq type="optional">kde-l10n-ve</packagereq>

+       <packagereq type="optional">kde-l10n-vi</packagereq>

+       <packagereq type="optional">kde-l10n-wa</packagereq>

+       <packagereq type="optional">kde-l10n-xh</packagereq>

+       <packagereq type="optional">kde-l10n-zh_CN</packagereq>

+       <packagereq type="optional">kde-l10n-zh_TW</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-libs</id>

+     <_name>KDE Libraries</_name>

+     <_description>Libraries made by KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="optional">kdesdk-kioslaves</packagereq>

+       <packagereq type="optional">kdesdk-thumbnailers</packagereq>

+       <packagereq type="optional">kdiagram</packagereq>

+       <packagereq type="optional">kdiagram-devel</packagereq>

+       <packagereq type="optional">kpmcore</packagereq>

+       <packagereq type="optional">kpmcore-devel</packagereq>

+       <packagereq type="optional">kproperty</packagereq>

+       <packagereq type="optional">kproperty-devel</packagereq>

+       <packagereq type="optional">kreport</packagereq>

+       <packagereq type="optional">kreport-devel</packagereq>

+       <packagereq type="optional">libalkimia</packagereq>

+       <packagereq type="optional">libalkimia-devel</packagereq>

+       <packagereq type="optional">libalkimia-doc</packagereq>

+       <packagereq type="optional">libalkimia-qt5</packagereq>

+       <packagereq type="optional">libalkimia-qt5-devel</packagereq>

+       <packagereq type="optional">libblockdev</packagereq>

+       <packagereq type="optional">libblockdev-btrfs</packagereq>

+       <packagereq type="optional">libblockdev-btrfs-devel</packagereq>

+       <packagereq type="optional">libblockdev-crypto</packagereq>

+       <packagereq type="optional">libblockdev-crypto-devel</packagereq>

+       <packagereq type="optional">libblockdev-devel</packagereq>

+       <packagereq type="optional">libblockdev-dm</packagereq>

+       <packagereq type="optional">libblockdev-dm-devel</packagereq>

+       <packagereq type="optional">libblockdev-fs</packagereq>

+       <packagereq type="optional">libblockdev-fs-devel</packagereq>

+       <packagereq type="optional">libblockdev-kbd</packagereq>

+       <packagereq type="optional">libblockdev-kbd-devel</packagereq>

+       <packagereq type="optional">libblockdev-loop</packagereq>

+       <packagereq type="optional">libblockdev-loop-devel</packagereq>

+       <packagereq type="optional">libblockdev-lvm</packagereq>

+       <packagereq type="optional">libblockdev-lvm-dbus</packagereq>

+       <packagereq type="optional">libblockdev-lvm-dbus-devel</packagereq>

+       <packagereq type="optional">libblockdev-lvm-devel</packagereq>

+       <packagereq type="optional">libblockdev-mdraid</packagereq>

+       <packagereq type="optional">libblockdev-mdraid-devel</packagereq>

+       <packagereq type="optional">libblockdev-mpath</packagereq>

+       <packagereq type="optional">libblockdev-mpath-devel</packagereq>

+       <packagereq type="optional">libblockdev-nvdimm</packagereq>

+       <packagereq type="optional">libblockdev-nvdimm-devel</packagereq>

+       <packagereq type="optional">libblockdev-part</packagereq>

+       <packagereq type="optional">libblockdev-part-devel</packagereq>

+       <packagereq type="optional">libblockdev-plugins-all</packagereq>

+       <packagereq type="optional">libblockdev-s390</packagereq>

+       <packagereq type="optional">libblockdev-s390-devel</packagereq>

+       <packagereq type="optional">libblockdev-swap</packagereq>

+       <packagereq type="optional">libblockdev-swap-devel</packagereq>

+       <packagereq type="optional">libblockdev-tools</packagereq>

+       <packagereq type="optional">libblockdev-utils</packagereq>

+       <packagereq type="optional">libblockdev-utils-devel</packagereq>

+       <packagereq type="optional">libblockdev-vdo</packagereq>

+       <packagereq type="optional">libblockdev-vdo-devel</packagereq>

+       <packagereq type="optional">libkcddb</packagereq>

        <packagereq type="optional">libkcddb-devel</packagereq>

+       <packagereq type="optional">libkcddb-doc</packagereq>

+       <packagereq type="optional">libkcompactdisc</packagereq>

        <packagereq type="optional">libkcompactdisc-devel</packagereq>

+       <packagereq type="optional">libkdeedu</packagereq>

        <packagereq type="optional">libkdeedu-devel</packagereq>

+       <packagereq type="optional">libkdeedu-static </packagereq>

+       <packagereq type="optional">libkdegames</packagereq>

        <packagereq type="optional">libkdegames-devel</packagereq>

-       <packagereq type="optional">marble-widget-devel</packagereq>

-       <packagereq type="optional">qt-creator</packagereq>

-       <packagereq type="optional">qt-mobility-devel</packagereq>

-       <packagereq type="optional">qt3-designer</packagereq>

-       <packagereq type="optional">qt3-devel</packagereq>

-       <packagereq type="optional">qtwebkit-devel</packagereq>

-       <packagereq type="optional">rocs-devel</packagereq>

+       <packagereq type="optional">libkdegames4</packagereq>

+       <packagereq type="optional">libkdegames4-devel</packagereq>

+       <packagereq type="optional">libkeduvocdocument</packagereq>

+       <packagereq type="optional">libkeduvocdocument-devel</packagereq>

+       <packagereq type="optional">libkfbapi</packagereq>

+       <packagereq type="optional">libkfbapi-devel</packagereq>

+       <packagereq type="optional">libkgapi</packagereq>

+       <packagereq type="optional">libkgapi-devel</packagereq>

+       <packagereq type="optional">libkmahjongg</packagereq>

+       <packagereq type="optional">libkmahjongg-data</packagereq>

+       <packagereq type="optional">libkmahjongg-devel</packagereq>

+       <packagereq type="optional">libkmahjongg4</packagereq>

+       <packagereq type="optional">libkmahjongg4-devel</packagereq>

+       <packagereq type="optional">libkomparediff2</packagereq>

+       <packagereq type="optional">libkomparediff2-devel</packagereq>

+       <packagereq type="optional">libksane</packagereq>

+       <packagereq type="optional">libksane-devel</packagereq>

+       <packagereq type="optional">libkscreen</packagereq>

+       <packagereq type="optional">libkscreen-devel</packagereq>

+       <packagereq type="optional">libkscreen-qt5</packagereq>

+       <packagereq type="optional">libkscreen-qt5-devel</packagereq>

+       <packagereq type="optional">libksysguard</packagereq>

+       <packagereq type="optional">libksysguard-common</packagereq>

+       <packagereq type="optional">libksysguard-devel</packagereq>

+       <packagereq type="optional">libkworkspace</packagereq>

+       <packagereq type="optional">libkworkspace5</packagereq>

+       <packagereq type="optional">mingw-qca</packagereq>

+       <packagereq type="optional">pykf5-kconfig-devel</packagereq>

+       <packagereq type="optional">python2-blockdev</packagereq>

+       <packagereq type="optional">python2-pykf5-kconfig</packagereq>

+       <packagereq type="optional">python3-blockdev</packagereq>

+       <packagereq type="optional">python3-kconfig</packagereq>

+       <packagereq type="optional">python3-pykf5-kconfig</packagereq>

+       <packagereq type="optional">qca</packagereq>

+       <packagereq type="optional">qca-botan</packagereq>

+       <packagereq type="optional">qca-cyrus-sasl</packagereq>

+       <packagereq type="optional">qca-devel</packagereq>

+       <packagereq type="optional">qca-doc</packagereq>

+       <packagereq type="optional">qca-gcrypt</packagereq>

+       <packagereq type="optional">qca-gnupg</packagereq>

+       <packagereq type="optional">qca-logger</packagereq>

+       <packagereq type="optional">qca-nss</packagereq>

+       <packagereq type="optional">qca-ossl</packagereq>

+       <packagereq type="optional">qca-pkcs11</packagereq>

+       <packagereq type="optional">qca-qt5</packagereq>

+       <packagereq type="optional">qca-qt5-botan</packagereq>

+       <packagereq type="optional">qca-qt5-cyrus-sasl</packagereq>

+       <packagereq type="optional">qca-qt5-devel</packagereq>

+       <packagereq type="optional">qca-qt5-gcrypt</packagereq>

+       <packagereq type="optional">qca-qt5-gnupg</packagereq>

+       <packagereq type="optional">qca-qt5-logger</packagereq>

+       <packagereq type="optional">qca-qt5-nss</packagereq>

+       <packagereq type="optional">qca-qt5-ossl</packagereq>

+       <packagereq type="optional">qca-qt5-pkcs11</packagereq>

+       <packagereq type="optional">qca-qt5-softstore</packagereq>

+       <packagereq type="optional">qca-softstore</packagereq>

+     </packagelist>

+   </group>

+   <group>

+     <id>kde-pim</id>

+     <_name>KDE Personal Information Management</_name>

+     <_description>PIM software made by KDE</_description>

+     <default>false</default>

+     <uservisible>true</uservisible>

+     <packagelist>

+       <packagereq type="default">akonadi</packagereq>

+       <packagereq type="optional">akonadi-calendar-tools</packagereq>

+       <packagereq type="optional">akonadi-devel</packagereq>

+       <packagereq type="default">akonadi-import-wizard</packagereq>

+       <packagereq type="optional">akonadi-import-wizard-devel</packagereq>

+       <packagereq type="default">akonadiconsole</packagereq>

+       <packagereq type="optional">kdepim-addons</packagereq>

+       <packagereq type="optional">kdepim-runtime</packagereq>

+       <packagereq type="optional">kgpg</packagereq>

+       <packagereq type="default">kleopatra</packagereq>

+       <packagereq type="default">kmail</packagereq>

+       <packagereq type="optional">kmail-account-wizard</packagereq>

+       <packagereq type="default">kmymoney</packagereq>

+       <packagereq type="optional">kmymoney-devel</packagereq>

+       <packagereq type="optional">kmymoney-doc</packagereq>

+       <packagereq type="default">knotes</packagereq>

+       <packagereq type="default">kontact</packagereq>

+       <packagereq type="default">korganizer</packagereq>

+       <packagereq type="optional">ktimetracker</packagereq>

+       <packagereq type="optional">mbox-importer</packagereq>

+       <packagereq type="optional">skrooge</packagereq>

      </packagelist>

    </group>

    <group>

-     <id>kde-telepathy</id>

-     <_name>KDE Telepathy</_name>

-     <_description>KDE Telepathy applications</_description>

+     <id>kde-plasma</id>

+     <_name>KDE Plasma</_name>

+     <_description>Software made by KDE as part of the KDE Plasma environment</_description>

      <default>false</default>

-     <uservisible>false</uservisible>

+     <uservisible>true</uservisible>

      <packagelist>

-       <packagereq>kaccounts-integration</packagereq>

-       <packagereq>kaccounts-providers</packagereq>

-       <packagereq>ktp-accounts-kcm</packagereq>

-       <packagereq>ktp-approver</packagereq>

-       <packagereq>ktp-auth-handler</packagereq>

-       <packagereq>ktp-contact-list</packagereq>

-       <packagereq>ktp-contact-runner</packagereq>

-       <packagereq>ktp-desktop-applets</packagereq>

-       <packagereq>ktp-filetransfer-handler</packagereq>

-       <packagereq>ktp-kded-integration-module</packagereq>

-       <packagereq>ktp-send-file</packagereq>

-       <packagereq>ktp-text-ui</packagereq>

-       <packagereq>signon-kwallet-extension</packagereq>

+       <packagereq type="default">bluedevil</packagereq>

+       <packagereq type="optional">colord-kde</packagereq>

+       <packagereq type="optional">kde-plasma-ihatethecashew</packagereq>

+       <packagereq type="optional">kde-plasma-ktorrent</packagereq>

+       <packagereq type="optional">kdeplasma-addons-devel</packagereq>

+       <packagereq type="optional">kdeplasma-addons</packagereq>

+       <packagereq type="optional">kgamma</packagereq>

+       <packagereq type="optional">khelpcenter</packagereq>

+       <packagereq type="optional">khelpcenter</packagereq>

+       <packagereq type="optional">khotkeys-devel</packagereq>

+       <packagereq type="optional">khotkeys</packagereq>

+       <packagereq type="optional">kinfocenter</packagereq>

+       <packagereq type="optional">kscreen</packagereq>

+       <packagereq type="optional">kscreenlocker-devel</packagereq>

+       <packagereq type="optional">kscreenlocker</packagereq>

+       <packagereq type="optional">ksshaskpass</packagereq>

+       <packagereq type="defaultl">ksysguard</packagereq>

+       <packagereq type="optional">ksysguardd</packagereq>

+       <packagereq type="default">kwayland-integration</packagereq>

+       <packagereq type="optional">kwin-common</packagereq>

+       <packagereq type="optional">kwin-devel</packagereq>

+       <packagereq type="optional">kwin-doc</packagereq>

+       <packagereq type="default">kwin-wayland</packagereq>

+       <packagereq type="default">kwin</packagereq>

+       <packagereq type="mandatory">plasma-desktop</packagereq>

+       <packagereq type="default">plasma-integration</packagereq>

+       <packagereq type="default">plasma-nm</packagereq>

+       <packagereq type="mandatory">plasma-workspace</packagereq>

+       <packagereq type="optional">powerdevil</packagereq>

+       <packagereq type="default">qqc2-desktop-style</packagereq>

+       <packagereq type="default">sddm-breeze</packagereq>

+       <packagereq type="optional">signon-kwallet-extension</packagereq>

+       <packagereq type="default">xdg-desktop-portal-kde</packagereq>

      </packagelist>

    </group>

    <group>

-     <id>kf5-software-development</id>

-     <_name>KDE Frameworks 5 Software Development</_name>

-     <_description>Install these packages to develop applications using Qt5 and KDE Frameworks 5.</_description>

+     <id>kde-themes</id>

+     <_name>KDE Themes</_name>

+     <_description>Themes made by KDE</_description>

      <default>false</default>

-     <uservisible>false</uservisible>

+     <uservisible>true</uservisible>

      <packagelist>

-       <packagereq type="mandatory">cmake</packagereq>

-       <packagereq type="mandatory">extra-cmake-modules</packagereq>

-       <packagereq type="default">qt5-qtdeclarative-devel</packagereq>

-       <packagereq type="default">qt5-qtquickcontrols</packagereq>

-       <packagereq type="default">qt5-qttools-devel</packagereq>

-       <packagereq type="default">qt5-qtwebkit-devel</packagereq>

-       <packagereq type="optional">qt-creator</packagereq>

-       <packagereq type="optional">qt5-qtconnectivity-devel</packagereq>

-       <packagereq type="optional">qt5-qtlocation-devel</packagereq>

-       <packagereq type="optional">qt5-qtmultimedia-devel</packagereq>

-       <packagereq type="optional">qt5-qtscript-devel</packagereq>

-       <packagereq type="optional">qt5-qtsensors-devel</packagereq>

-       <packagereq type="optional">qt5-qtserialport-devel</packagereq>

-       <packagereq type="optional">qt5-qtsvg-devel</packagereq>

-       <packagereq type="optional">qt5-qtwayland-devel</packagereq>

-       <packagereq type="optional">qt5-qtx11extras-devel</packagereq>

-       <packagereq type="optional">qt5-qtxmlpatterns-devel</packagereq>

+       <packagereq type="default">breeze-gtk</packagereq>

+       <packagereq type="default">breeze-icon-theme</packagereq>

+       <packagereq type="optional">breeze-icon-theme-rcc</packagereq>

+       <packagereq type="optional">grub2-breeze-theme</packagereq>

+       <packagereq type="optional">kde-colorscheme-plastik</packagereq>

+       <packagereq type="default">kde-wallpapers</packagereq>

+       <packagereq type="default">plasma-breeze</packagereq>

+       <packagereq type="optional">qt5-style-oxygen</packagereq>

      </packagelist>

    </group>

    <group>
@@ -5840,15 +6644,21 @@ 

        <groupid>hardware-support</groupid>

        <groupid>printing</groupid>

        <groupid>guest-desktop-agents</groupid>

-       <groupid>kde-desktop</groupid>

+       <groupid>kde-plasma</groupid>

+       <groupid>kde-system</groupid>

+       <groupid>kde-utilities</groupid>

+       <groupid>kde-kcms</groupid>

+       <groupid>kde-themes</groupid>

+       <groupid>kde-fedora-branding</groupid>

      </grouplist>

      <optionlist>

        <groupid default="true">firefox</groupid>

-       <groupid default="true">kde-apps</groupid>

+       <groupid>kde-graphics</groupid>

+       <groupid>kde-network</groupid>

+       <groupid default="true">kde-multimedia</groupid>

        <groupid>kde-education</groupid>

-       <groupid default="true">kde-media</groupid>

        <groupid default="true">kde-office</groupid>

-       <groupid>kde-telepathy</groupid>

+       <groupid>kde-pim</groupid>

        <groupid>3d-printing</groupid>

        <groupid>cloud-management</groupid>

      </optionlist>
@@ -6256,7 +7066,7 @@ 

        <groupid>cinnamon-desktop</groupid>

        <groupid>gnome-desktop</groupid>

        <groupid>input-methods</groupid>

-       <groupid>kde-desktop</groupid>

+       <groupid>kde-plasma</groupid>

        <groupid>legacy-fonts</groupid>

        <groupid>libreoffice</groupid>

        <groupid>lxde-desktop</groupid>
@@ -6270,16 +7080,16 @@ 

    </environment>

    <category>

      <id>kde-desktop-environment</id>

-     <_name>KDE Desktop</_name>

-     <_description>The KDE SC includes the KDE Plasma Desktop, a highly-configurable graphical user interface which includes a panel, desktop, system icons and desktop widgets, and many powerful KDE applications.</_description>

+     <_name>KDE Plasma</_name>

+     <_description>KDE Plasma is a highly-configurable graphical user interface which includes a panel, desktop, system icons and desktop widgets.</_description>

      <display_order>10</display_order>

      <grouplist>

-       <groupid>kde-apps</groupid>

-       <groupid>kde-desktop</groupid>

+       <groupid>kde-plasma</groupid>

+       <groupid>kde-graphics</groupid>

+       <groupid>kde-network</groupid>

+       <groupid>kde-multimedia</groupid>

        <groupid>kde-education</groupid>

-       <groupid>kde-media</groupid>

        <groupid>kde-office</groupid>

-       <groupid>kde-telepathy</groupid>

      </grouplist>

    </category>

    <category>

Not really much to say here. All thousand or so Fedora packages of KDE things are sorted into groups.

Fixes #204 and #205.

@appadeia Why is everything now "optional"? That means they're not getting installed by default anymore.

  • default -> Recommends
  • mandatory -> Requires
  • optional -> Suggests

Indeed, optional should only be used for the packages that were previously not listed at all, or that the KDE SIG decided to drop from the default installation. Everything else (i.e., all packages that should be installed on the Spin) should usually be default, or only in some special cases (when it really makes no sense whatsoever to install the group without that particular package) mandatory.

2 new commits added

  • Tag some stuff as default
  • Fix office typo
2 years ago

@rdieter, could you please review this?

maybe a good start, but not merge-worthy yet.

Issues:
1. Some groups went missing, examples include:
kde-apps
kde-desktop
This will break composing spins

Maybe need to do this in 2 phases, introduce the new groups in phase 1, then maybe deprecate/remove some old groups (like kde-apps) in phase 2.

  1. Some packages went missing (possibly related to item 1), examples include:
    plasma-nm

  2. comps should generally not include -libs subpkgs, examples
    ktorrent-libs
    amarok-libs
    konqueror-libs

rebased onto 9e4c4dc550287402df552e3dac9ac8dd0677a40e

2 years ago

rebased onto 87c597b8cf6bcc91a38bf217a5ed9111158aeed9

2 years ago

1 new commit added

  • Drop *-libs subpackages
2 years ago

1 new commit added

  • Tidy up some oversights
2 years ago

This will break composing spins

I've been meaning to send a corresponding patch to fedora-kickstarts anyhow. Perhaps landing the two could be coordinated.

rebased onto 8008e0d5c51b2bd4c4136e54ed94fc312fb655e2

2 years ago

1 new commit added

  • Tidy the categories and environments to reflect the rewritten groups
2 years ago

rebased onto 22d23e9

2 years ago

What's the status here?

Pull-Request has been closed by appadeia

2 years ago

Got closed without comment, so I guess there's not much to do here now?

Got closed without comment, so I guess there's not much to do here now?

if you want to use the resulting work, you can.

i don't really have any motivation to push this forward because of the awfulness of this repo's workflow requiring me to put in a few more hours of churn just to rebase this on the latest version + the fact that this + related PR haven't been looked at for months on end now.

Metadata