#285 all: drag in NetworkManager-ppp package for Modem support
Merged a year ago by pbrobinson. Opened a year ago by lkundrak.
lkundrak/fedora-comps lr/ppp-wwan  into  master

file modified
+1

@@ -319,6 +319,7 @@ 

        <packagereq>NetworkManager-libreswan-gnome</packagereq>

        <packagereq>NetworkManager-openconnect-gnome</packagereq>

        <packagereq>NetworkManager-openvpn-gnome</packagereq>

+       <packagereq>NetworkManager-ppp</packagereq>

        <packagereq>NetworkManager-pptp-gnome</packagereq>

        <packagereq>NetworkManager-vpnc-gnome</packagereq>

        <packagereq>NetworkManager-wifi</packagereq>

file modified
+6

@@ -593,6 +593,7 @@ 

        <packagereq type="mandatory">NetworkManager-libreswan-gnome</packagereq>

        <packagereq type="mandatory">NetworkManager-openconnect-gnome</packagereq>

        <packagereq type="mandatory">NetworkManager-openvpn-gnome</packagereq>

+       <packagereq type="mandatory">NetworkManager-ppp</packagereq>

        <packagereq type="mandatory">NetworkManager-pptp-gnome</packagereq>

        <packagereq type="mandatory">NetworkManager-vpnc-gnome</packagereq>

        <packagereq type="mandatory">NetworkManager-wifi</packagereq>

@@ -1152,6 +1153,8 @@ 

        <packagereq type="default">minicom</packagereq>

        <packagereq type="default">ModemManager</packagereq>

        <packagereq type="default">NetworkManager-adsl</packagereq>

+       <packagereq type="default">NetworkManager-ppp</packagereq>

+       <packagereq type="default">NetworkManager-wwan</packagereq>

        <packagereq type="default">rp-pppoe</packagereq>

        <packagereq type="default">wvdial</packagereq>

        <packagereq type="optional">efax</packagereq>

@@ -2735,9 +2738,11 @@ 

        <packagereq>NetworkManager-adsl</packagereq>

        <packagereq>NetworkManager-openconnect-gnome</packagereq>

        <packagereq>NetworkManager-openvpn-gnome</packagereq>

+       <packagereq>NetworkManager-ppp</packagereq>

        <packagereq>NetworkManager-pptp-gnome</packagereq>

        <packagereq>NetworkManager-ssh-gnome</packagereq>

        <packagereq>NetworkManager-vpnc-gnome</packagereq>

+       <packagereq>NetworkManager-wwan</packagereq>

        <packagereq>orca</packagereq>

        <packagereq>PackageKit-command-not-found</packagereq>

        <packagereq>PackageKit-gtk3-module</packagereq>

@@ -4464,6 +4469,7 @@ 

        <packagereq>NetworkManager-libreswan-gnome</packagereq>

        <packagereq>NetworkManager-openconnect-gnome</packagereq>

        <packagereq>NetworkManager-openvpn-gnome</packagereq>

+       <packagereq>NetworkManager-ppp</packagereq>

        <packagereq>NetworkManager-pptp-gnome</packagereq>

        <packagereq>NetworkManager-vpnc-gnome</packagereq>

        <packagereq>NetworkManager-wifi</packagereq>

file modified
+6

@@ -593,6 +593,7 @@ 

        <packagereq type="mandatory">NetworkManager-libreswan-gnome</packagereq>

        <packagereq type="mandatory">NetworkManager-openconnect-gnome</packagereq>

        <packagereq type="mandatory">NetworkManager-openvpn-gnome</packagereq>

+       <packagereq type="mandatory">NetworkManager-ppp</packagereq>

        <packagereq type="mandatory">NetworkManager-pptp-gnome</packagereq>

        <packagereq type="mandatory">NetworkManager-vpnc-gnome</packagereq>

        <packagereq type="mandatory">NetworkManager-wifi</packagereq>

@@ -1155,6 +1156,8 @@ 

        <packagereq type="default">minicom</packagereq>

        <packagereq type="default">ModemManager</packagereq>

        <packagereq type="default">NetworkManager-adsl</packagereq>

+       <packagereq type="default">NetworkManager-ppp</packagereq>

+       <packagereq type="default">NetworkManager-wwan</packagereq>

        <packagereq type="default">rp-pppoe</packagereq>

        <packagereq type="default">wvdial</packagereq>

        <packagereq type="optional">efax</packagereq>

@@ -2718,9 +2721,11 @@ 

        <packagereq>NetworkManager-adsl</packagereq>

        <packagereq>NetworkManager-openconnect-gnome</packagereq>

        <packagereq>NetworkManager-openvpn-gnome</packagereq>

+       <packagereq>NetworkManager-ppp</packagereq>

        <packagereq>NetworkManager-pptp-gnome</packagereq>

        <packagereq>NetworkManager-ssh-gnome</packagereq>

        <packagereq>NetworkManager-vpnc-gnome</packagereq>

+       <packagereq>NetworkManager-wwan</packagereq>

        <packagereq>orca</packagereq>

        <packagereq>PackageKit-command-not-found</packagereq>

        <packagereq>PackageKit-gtk3-module</packagereq>

@@ -4434,6 +4439,7 @@ 

        <packagereq>NetworkManager-libreswan-gnome</packagereq>

        <packagereq>NetworkManager-openconnect-gnome</packagereq>

        <packagereq>NetworkManager-openvpn-gnome</packagereq>

+       <packagereq>NetworkManager-ppp</packagereq>

        <packagereq>NetworkManager-pptp-gnome</packagereq>

        <packagereq>NetworkManager-vpnc-gnome</packagereq>

        <packagereq>NetworkManager-wifi</packagereq>

The PPP support has been moved to an spearate package, but the comps
haven't been updated accordingly.

PPP support is required for a fair number of modems to work -- install
it everywhere where modems are supposed to work.

Commit 7853914 fixes this pull-request

Pull-Request has been merged by pbrobinson

a year ago

Pull-Request has been merged by pbrobinson

a year ago