#46 Unable to upgrade dotnet/install 2.0&2.1 sdk side-by-side.
Closed 2 years ago Opened 3 years ago by tmds.

I have dotnet installed:

~$ dnf list installed | grep dotnet
dotnet-host.x86_64                         2.0.6-2.fc27                @group_dotnet-sig-dotnet
dotnet-runtime-2.0.x86_64                  2.0.3-5.fc27                @group_dotnet-sig-dotnet
dotnet-sdk-2.0.x86_64                      2.0.3-5.fc27                @group_dotnet-sig-dotnet

When I try to update it fails:

$ sudo dnf install dotnet
Last metadata expiration check: 2:20:37 ago on Wed 16 May 2018 10:26:26 AM CEST.
 Problem: package dotnet-2.0.7-1.fc27.x86_64 requires dotnet-sdk-2.1(x86-64) = 2.0.7-1.fc27, but none of the providers can be installed
  - package dotnet-sdk-2.1-2.0.7-1.fc27.x86_64 requires dotnet-runtime-2.0(x86-64) = 2.0.7-1.fc27, but none of the providers can be installed
  - conflicting requests
  - cannot install both dotnet-runtime-2.0-2.0.7-1.fc27.x86_64 and dotnet-runtime-2.0-2.0.3-5.fc27.x86_64
  - problem with installed package dotnet-sdk-2.0-2.0.3-5.fc27.x86_64
  - package dotnet-sdk-2.0-2.0.3-5.fc27.x86_64 requires dotnet-runtime-2.0(x86-64) = 2.0.3-5.fc27, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

It seems there is an issue having both sdks installed.
I manually removed: dotnet-sdk-2.0 and installed dotnet-sdk-2.1.

If i understand it right, it's trying to install new sdk that requires newer version of the runtime that you have, you would need to manually update first to get up to date runtime, and then you might be able to install the 2.1 - having the same version of runtime

I think I understand the problem. We have each build of the sdk package tied to an exact version of the runtime package. So installing sdk 2.0 and 2.1 will pull in different builds of runtime 2.0. What we should do instead is to say that sdk-2.0 requires a certain minimum version of runtime-2.0 and sdk-2.1 requires a certain (but different) minimum version of runtime-2.0. Then a more recent version of runtime-2.0 will satisfy both requirements.

This was fixed. I can install the 2.1.2xx and 2.1.3xx sdks in paralell:

$ rpm -qa | grep dotnet

Metadata Update from @omajid:
- Issue assigned to omajid

2 years ago

Metadata Update from @omajid:
- Issue status updated to: Closed (was: Open)

2 years ago

Login to comment on this ticket.