#3201 unittest warnings
Closed: fixed a year ago by edewata. Opened a year ago by slev.

There are several identical unittest deprecation warnings:

=============================== warnings summary ===============================
tests/python/test_authority.py::AuthorityTests::test_should_create_subca
  /usr/src/RPM/BUILD/pki-core-10.7.4/tests/python/test_authority.py:73: DeprecationWarning: Please use assertEqual instead.
    self.assertEquals(ca.aid, self.aid)

tests/python/test_authority.py::AuthorityTests::test_should_create_subca
  /usr/src/RPM/BUILD/pki-core-10.7.4/tests/python/test_authority.py:74: DeprecationWarning: Please use assertEqual instead.
    self.assertEquals(ca.dn, self.dn)

tests/python/test_authority.py::AuthorityTests::test_should_get_ca
  /usr/src/RPM/BUILD/pki-core-10.7.4/tests/python/test_authority.py:116: DeprecationWarning: Please use assertEqual instead.
    self.assertEquals(ca.aid, self.aid)

tests/python/test_authority.py::AuthorityTests::test_should_get_ca
  /usr/src/RPM/BUILD/pki-core-10.7.4/tests/python/test_authority.py:117: DeprecationWarning: Please use assertEqual instead.
    self.assertEquals(ca.dn, self.dn)

tests/python/test_authority.py::AuthorityTests::test_should_list_cas
  /usr/src/RPM/BUILD/pki-core-10.7.4/tests/python/test_authority.py:131: DeprecationWarning: Please use assertEqual instead.
    self.assertEquals(ca.dn, self.dn)

tests/python/test_authority.py::AuthorityTests::test_should_list_cas
  /usr/src/RPM/BUILD/pki-core-10.7.4/tests/python/test_authority.py:129: DeprecationWarning: Please use assertEqual instead.
    self.assertEquals(ca.dn, self.dn2)

assertEquals is deprecated in favor of assertEqual since:
https://docs.python.org/3/whatsnew/3.2.html

$ find -name '*.py' -exec grep -H assertEquals {} \;
./tests/python/test_authority.py:        self.assertEquals(ca.aid, self.aid)
./tests/python/test_authority.py:        self.assertEquals(ca.dn, self.dn)
./tests/python/test_authority.py:        self.assertEquals(ca.aid, self.aid)
./tests/python/test_authority.py:        self.assertEquals(ca.dn, self.dn)
./tests/python/test_authority.py:                self.assertEquals(ca.dn, self.dn2)
./tests/python/test_authority.py:                self.assertEquals(ca.dn, self.dn)
./tests/python/test_pki_keyring.py:        self.assertEquals(retrieved_key_id, orig_key_id)
./tests/python/test_pki_keyring.py:        self.assertEquals(retrieved_pass_hex.strip(), orig_pass.encode().hex())

Metadata Update from @edewata:
- Custom field component adjusted to None
- Custom field feature adjusted to None
- Custom field origin adjusted to None
- Custom field proposedmilestone adjusted to None
- Custom field proposedpriority adjusted to None
- Custom field reviewer adjusted to None
- Custom field type adjusted to None
- Custom field version adjusted to None
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

a year ago

Dogtag PKI is moving from Pagure issues to GitHub issues. This means that existing or new
issues will be reported and tracked through Dogtag PKI's GitHub Issue tracker.

This issue has been cloned to GitHub and is available here:
https://github.com/dogtagpki/pki/issues/3318

If you want to receive further updates on the issue, please navigate to the
GitHub issue and click on Subscribe button.

Thank you for understanding, and we apologize for any inconvenience.

Login to comment on this ticket.

Metadata