#11 Upgrade the Mailman stack
Opened 2 years ago by abompard. Modified 2 years ago

The Mailman stack is not up-to-date and needs upgrading.

The problem is that newer versions of Mailman require Python >= 3.5 and we were currently building it with Python 3.4 in EPEL. To rebuild a newer Mailman and its dependences we need them ported to the new python36 in EPEL.


There has been a proposal to enable Python3.6 for the python packages in EPEL but it's still at the planning stage. It's a lot of grunt work. See https://lists.fedoraproject.org/archives/list/python-devel@lists.fedoraproject.org/thread/WIDTOW7HUOJI3QO4WNCG2DTTF5B3CLBE/

Python3.6 will arrive in EPEL-7 after April 2nd. This can proceed next.

Metadata Update from @smooge:
- Issue priority set to: None (was: 1)

2 years ago

Login to comment on this ticket.

Metadata