#102 support libidn2
Closed: fixed 2 years ago Opened 2 years ago by pbrobinson.

libidn2 supports the IDNA2008 + TR46 standards, where as libidn only supports IDN2003. According to the README [1] it's API is backwards compatible with the oriignal libidn. To quote " Replacing the
idna.h header with idn2.h into a program is sufficient to switch the application from IDNA2003 to IDNA2008 as supported by this library."

It would be useful to be able to build against the newer library as most core bits in Fedora use the newer library.

[1] https://gitlab.com/libidn/libidn2/blob/master/README.md


Metadata Update from @rcritten:
- Issue assigned to rcritten

2 years ago

Metadata Update from @rcritten:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

2 years ago

Login to comment on this ticket.

Metadata