2bc70d6 Attempt to support both BIND 9.11 and 9.16

12 files Authored by pemensik 10 months ago, Committed by abbra 10 months ago,
    Attempt to support both BIND 9.11 and 9.16
    
    Use LIBDNS_VERSION_MAJOR compatibility macro to provide
    few workarounds to compile even with 9.11. Try to minimize
    changes of public API, but not everywhere it was possible.
    
    ldapdb_associate should be moved back to header, but it would require
    header modified on configure time.
    
        
file modified
+4 -0
file modified
+4 -0
file modified
+11 -2
file modified
+4 -0
file modified
+58 -17
file modified
+2 -0
file modified
+25 -1
file modified
+24 -2
file modified
+5 -0
file modified
+9 -0
file modified
+4 -0
file modified
+20 -4