#3588 sssd_nss consumes more memory until restarted or machine swaps
Closed: Fixed 2 years ago Opened 2 years ago by lslebodn.

    ==00:01:01:29.871 10088== 934,414 bytes in 8,731 blocks are definitely lost in loss record 121 of 121
    ==00:01:01:29.871 10088==    at 0x4C29BE3: malloc (vg_replace_malloc.c:299)
    ==00:01:01:29.871 10088==    by 0x8FF4EAB: talloc_strdup (in /usr/lib64/libtalloc.so.2.1.9)
    ==00:01:01:29.871 10088==    by 0x52933B9: sss_output_name (usertools.c:808)
    ==00:01:01:29.871 10088==    by 0x5293550: sss_output_fqname (usertools.c:863)
    ==00:01:01:29.871 10088==    by 0x1211F9: sized_output_name (responder_common.c:1708)
    ==00:01:01:29.871 10088==    by 0x1137E6: memcache_delete_entry (nss_get_object.c:112)
    ==00:01:01:29.871 10088==    by 0x113BB6: nss_get_object_done (nss_get_object.c:245)
    ==00:01:01:29.871 10088==    by 0x8DE5291: _tevent_req_error (in /usr/lib64/libtevent.so.0.9.31)
    ==00:01:01:29.871 10088==    by 0x1276CE: cache_req_done (cache_req.c:1047)
    ==00:01:01:29.871 10088==    by 0x8DE5291: _tevent_req_error (in /usr/lib64/libtevent.so.0.9.31)
    ==00:01:01:29.871 10088==    by 0x126AF6: cache_req_search_domains_done (cache_req.c:607)
    ==00:01:01:29.871 10088==    by 0x8DE4AB9: tevent_common_loop_immediate (in /usr/lib64/libtevent.so.0.9.31)
    ==00:01:01:29.871 10088==    by 0x8DE9C9C: ??? (in /usr/lib64/libtevent.so.0.9.31)
    ==00:01:01:29.871 10088==    by 0x8DE82A6: ??? (in /usr/lib64/libtevent.so.0.9.31)
    ==00:01:01:29.871 10088==    by 0x8DE40CC: _tevent_loop_once (in /usr/lib64/libtevent.so.0.9.31)
    ==00:01:01:29.871 10088==    by 0x8DE42FA: tevent_common_loop_wait (in /usr/lib64/libtevent.so.0.9.31)
    ==00:01:01:29.871 10088==    by 0x8DE8246: ??? (in /usr/lib64/libtevent.so.0.9.31)
    ==00:01:01:29.871 10088==    by 0x5291B32: server_loop (server.c:718)
    ==00:01:01:29.871 10088==    by 0x11004C: main (nsssrv.c:560)

Metadata Update from @lslebodn:
- Issue assigned to lslebodn

2 years ago

Metadata Update from @lslebodn:
- Issue tagged with: PR, regression

2 years ago

Regression was introduced in 1.15.3
a012a71

Metadata Update from @lslebodn:
- Custom field version adjusted to 1.15.3

2 years ago

Metadata Update from @lslebodn:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=1482231

2 years ago

Metadata Update from @lslebodn:
- Issue close_status updated to: Fixed
- Issue set to the milestone: SSSD 1.16.1
- Issue status updated to: Closed (was: Open)

2 years ago

Login to comment on this ticket.

Metadata