#3340 The option enable_files_domain does not work if sssd is not compiled with --enable-files-domain

Created a month ago by lslebodn
Modified 15 days ago

How to reproduce:

  1. ensure that sssd is not enabled with --enable-files-domain. Man page contains Default false for enable_files_domain in man sssd.conf
       enable_files_domain (boolean)
           When this option is enabled, SSSD prepends an implicit domain with
           “id_provider=files” before any explicitly configured domains.

           Default: false
  1. Enable enable_files_domain in [sssd] section of /etc/sssd/sssd.conf
    e.g.
[sssd]
enable_files_domain = true
services = nss, pam
domains = example.com

...
  1. Start sssd

Expected output:
There is sssd_be process for domain implicit_files
e.g.

pgrep -af sssd
23654 /usr/sbin/sssd -i -f
23672 /usr/libexec/sssd/sssd_be --domain implicit_files --uid 0 --gid 0 --debug-to-files
23673 /usr/libexec/sssd/sssd_be --domain redhat.com --uid 0 --gid 0 --debug-to-files
23683 /usr/libexec/sssd/sssd_nss --uid 0 --gid 0 --debug-to-files
23684 /usr/libexec/sssd/sssd_pam --uid 0 --gid 0 --debug-to-files

Actual output:
Just one sssd_be process
e.g.

pgrep -af sssd
23654 /usr/sbin/sssd -i -f
23673 /usr/libexec/sssd/sssd_be --domain redhat.com --uid 0 --gid 0 --debug-to-files
23683 /usr/libexec/sssd/sssd_nss --uid 0 --gid 0 --debug-to-files
23684 /usr/libexec/sssd/sssd_pam --uid 0 --gid 0 --debug-to-files
a month ago

Metadata Update from @jhrozek:
- Issue set to the milestone: SSSD 1.15.4

20 days ago

Metadata Update from @lslebodn:
- Issue assigned to lslebodn

master:

  • 3509bb03ecef49264820c9e287e8b2c7e0a8a508
15 days ago

Metadata Update from @lslebodn:
- Custom field patch adjusted to on
- Custom field version adjusted to 1.1.51

15 days ago

Metadata Update from @lslebodn:
- Issue close_status updated to: Fixed
- Issue set to the milestone: SSSD 1.15.3 (was: SSSD 1.15.4)
- Issue status updated to: Closed (was: Open)

Login to comment on this ticket.

1.1.51

on

cancel