#3340 The option enable_files_domain does not workis sssd is not compiled with --enable-files-domain

Created 11 days ago by lslebodn
Modified 4 days ago

How to reproduce:

  1. ensure that sssd is not enabled with --enable-files-domain. Man page contains Default false for enable_files_domain in man sssd.conf
       enable_files_domain (boolean)
           When this option is enabled, SSSD prepends an implicit domain with
           “id_provider=files” before any explicitly configured domains.

           Default: false
  1. Enable enable_files_domain in [sssd] section of /etc/sssd/sssd.conf
    e.g.
[sssd]
enable_files_domain = true
services = nss, pam
domains = example.com

...
  1. Start sssd

Expected output:
There is sssd_be process for domain implicit_files
e.g.

pgrep -af sssd
23654 /usr/sbin/sssd -i -f
23672 /usr/libexec/sssd/sssd_be --domain implicit_files --uid 0 --gid 0 --debug-to-files
23673 /usr/libexec/sssd/sssd_be --domain redhat.com --uid 0 --gid 0 --debug-to-files
23683 /usr/libexec/sssd/sssd_nss --uid 0 --gid 0 --debug-to-files
23684 /usr/libexec/sssd/sssd_pam --uid 0 --gid 0 --debug-to-files

Actual output:
Just one sssd_be process
e.g.

pgrep -af sssd
23654 /usr/sbin/sssd -i -f
23673 /usr/libexec/sssd/sssd_be --domain redhat.com --uid 0 --gid 0 --debug-to-files
23683 /usr/libexec/sssd/sssd_nss --uid 0 --gid 0 --debug-to-files
23684 /usr/libexec/sssd/sssd_pam --uid 0 --gid 0 --debug-to-files
4 days ago

Metadata Update from @jhrozek:
- Issue set to the milestone: SSSD 1.15.4

Login to comment on this ticket.

cancel