#2837 REGRESSION: ipa-client-automout failed
Closed: Fixed None Opened 5 years ago by lslebodn.

ipa-client-automout failed to import sssd.conf without config_file_version

# ipa-client-automount --server=hp-dl380pgen8-01.lsamnt2k8r2.test  --location=trust_location -U'
IPA server: hp-dl380pgen8-01.lsamnt2k8r2.test
Location: trust_location
Configured /etc/sysconfig/nfs
Configured /etc/idmapd.conf
Started rpcidmapd
Started rpcgssd
File contains no config_file_version

Can we fix ipa-client-automout instead? How would we fix this in SSSD?

It's a bug in python SSSDConfig. ipa-automount-install does nothing with config_file_version

I am working on unit test.

Michal, please reassign back to somebody if don't plan on working on this issue.

milestone: NEEDS_TRIAGE => SSSD 1.13.3
owner: somebody => mzidek

Fields changed

rhbz: => todo

Fields changed

milestone: SSSD 1.13.3 => SSSD 1.13.2
resolution: => fixed
status: new => closed

Fields changed

rhbz: todo => 0

Metadata Update from @lslebodn:
- Issue assigned to mzidek
- Issue set to the milestone: SSSD 1.13.2

3 years ago

SSSD is moving from Pagure to Github. This means that new issues and pull requests
will be accepted only in SSSD's github repository.

This issue has been cloned to Github and is available here:
- https://github.com/SSSD/sssd/issues/3878

If you want to receive further updates on the issue, please navigate to the github issue
and click on subscribe button.

Thank you for understanding. We apologize for all inconvenience.

Login to comment on this ticket.

Metadata