#2768 Test 'test_id_cleanup_exp_group' failed
Closed: Fixed None Opened 3 years ago by pcech.

I can reproduce it on my machine. (Maybe I am the only one.)

There is a part of log:

(Thu Aug 20 07:40:49:577840 2015) [sssd] [test_multidom_suite_cleanup] (0x0020): Could not delete the test config ldb file [20]: (Not a directory)
(Thu Aug 20 07:40:49:577887 2015) [sssd] [test_multidom_suite_cleanup] (0x0020): Could not delete the test domain ldb file [20]: (Not a directory)
(Thu Aug 20 07:40:49:577899 2015) [sssd] [test_multidom_suite_cleanup] (0x0020): Could not delete the test dir (20) (Not a directory)
[==========] Running 1 test(s).
[ RUN      ] test_id_cleanup_exp_group
(Thu Aug 20 07:40:49:578773 2015) [sssd] [ldb] (0x0020): Unable to open tdb 'test_ldap_id_cleanup/tests_conf.ldb': Not a directory
(Thu Aug 20 07:40:49:578786 2015) [sssd] [ldb] (0x0020): Failed to connect to 'test_ldap_id_cleanup/tests_conf.ldb' with backend 'tdb': Unable to open tdb 'test_ldap_id_cleanup/tests_conf.ldb': Not a directory
(Thu Aug 20 07:40:49:578791 2015) [sssd] [confdb_init] (0x0010): Unable to open config database [test_ldap_id_cleanup/tests_conf.ldb]
Could not run the test - check test fixtures
[  ERROR   ] test_id_cleanup_exp_group
[==========] 1 test(s) run.
[  PASSED  ] 0 test(s).
FAIL test_ldap_id_cleanup (exit status: 1)

I hit this bug as well.

Unfortunately, I cannot effort to spend time with fixing totally broken patch which I rejected. I will locally maintain patch which disable this test until it will be fixed in upstream. The author of patch should have enough knowledge about his test; therefore assigning this ticket to him.

owner: somebody => preichl

Fields changed

patch: 0 => 1

milestone: NEEDS_TRIAGE => SSSD 1.13.1
resolution: => fixed
status: new => closed

Fields changed

rhbz: => 0

Metadata Update from @pcech:
- Issue assigned to preichl
- Issue set to the milestone: SSSD 1.13.1

2 years ago

Login to comment on this ticket.

Metadata