#1845 move libsss_sudo and libsss_autofs back into the main sssd package
Closed: Fixed None Opened 6 years ago by jhrozek.

libsss_sudo and libsss_autofs are separate packages that contain just a single client library with no additional dependencies. This separation comes from the F-17 timeframe where the feature was really just a tech preview so we didn't want it to be packaged in sssd proper. On the other hand users are getting regularly confused about "sudo not working" when all they really miss is the single library.

I think we should move these libraries into the main sssd package. There is also libsss_sudo-devel that contains documentation on the API but I don't think we need to keep building it by default. It's not a 3rd party API.


Fields changed

milestone: NEEDS_TRIAGE => SSSD 1.10.0

I will fix this together with #1510.

changelog: =>
owner: somebody => jhrozek
status: new => assigned

Fields changed

patch: 0 => 1

resolution: => fixed
status: assigned => closed

Moving to 1.10 beta where the ticket was actually fixed.

milestone: SSSD 1.10.0 => SSSD 1.10 beta

Metadata Update from @jhrozek:
- Issue assigned to jhrozek
- Issue set to the milestone: SSSD 1.10 beta

2 years ago

Login to comment on this ticket.

Metadata