#1772 Rename or alias the SAFEALIGN macros
Closed: Fixed None Opened 9 years ago by sgallagh.

Right now, it's not easy to understand which SAFEALIGN macro to use in a given scenario. Choosing between SET and COPY is unclear. We should rename or alias the macros so that it's more clear that we want to use the SET macro when copying a variable into a byte-buffer and COPY when we are pulling data out of a byte buffer into a variable.

I'm not sure what to call these new macros, maybe {{{SAFEALIGN_BUFFER_PACK_<type>}}} and {{{SAFEALIGN_BUFFER_UNPACK_<type>}}}?

Fields changed

milestone: NEEDS_TRIAGE => SSSD 1.10 beta
priority: major => minor
rhbz: => 0

Fields changed

owner: somebody => mzidek

Not critical for beta, can be done in 1.10 proper

milestone: SSSD 1.10 beta => SSSD 1.10.0
review: => 0

Fields changed

patch: 0 => 1

milestone: SSSD 1.10.0 => SSSD 1.10 beta
resolution: => fixed
status: new => closed

Metadata Update from @sgallagh:
- Issue assigned to mzidek
- Issue set to the milestone: SSSD 1.10 beta

5 years ago

SSSD is moving from Pagure to Github. This means that new issues and pull requests
will be accepted only in SSSD's github repository.

This issue has been cloned to Github and is available here:
- https://github.com/SSSD/sssd/issues/2814

If you want to receive further updates on the issue, please navigate to the github issue
and click on subscribe button.

Thank you for understanding. We apologize for all inconvenience.

Login to comment on this ticket.