#49857 RPM scriptlet for 389-ds-base-legacy-tools throws an error: line 29: [: -eq: unary operator expected
Closed: wontfix 3 years ago Opened 3 years ago by vashirov.

Issue Description

On a fresh instance of Fedora 28 I see the following error:

  Installing       : 389-ds-base-legacy-tools-1.4.0.11-2.fc28.x86_64                                                                                     40/41 
  Running scriptlet: 389-ds-base-legacy-tools-1.4.0.11-2.fc28.x86_64                                                                                     40/41 
/var/tmp/rpm-tmp.qFWddf: line 29: [: -eq: unary operator expected

Package Version and Platform

389-ds-base-legacy-tools.x86_64 1.4.0.11-2.fc28

Steps to reproduce

On a fresh F28
1. yum install 389-ds-base

Actual results

Scriptlet throws an error if no instances are present.

Expected results

There shouldn't be an error during installation of RPM.


Metadata Update from @mreynolds:
- Issue assigned to mreynolds

3 years ago

Metadata Update from @mreynolds:
- Custom field component adjusted to None
- Custom field origin adjusted to None
- Custom field reviewstatus adjusted to None
- Custom field type adjusted to None
- Custom field version adjusted to None
- Issue set to the milestone: 1.4.0

3 years ago

Metadata Update from @mreynolds:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

3 years ago

389-ds-base is moving from Pagure to Github. This means that new issues and pull requests
will be accepted only in 389-ds-base's github repository.

This issue has been cloned to Github and is available here:
- https://github.com/389ds/389-ds-base/issues/2916

If you want to receive further updates on the issue, please navigate to the github issue
and click on subscribe button.

Thank you for understanding. We apologize for all inconvenience.

Metadata Update from @spichugi:
- Issue close_status updated to: wontfix (was: fixed)

2 years ago

Login to comment on this ticket.

Metadata