#425 support multiple winsync plugins
Closed: Fixed None Opened 7 years ago by rmeggins.

We should have the ability to have multiple winsync plugins. We should use the same slapi plugin precedence model to control in which order the plugins are called.


Looks good!

It looks like plug-ins using the v1 and v2 API's get a precedence of 50, so new v3 plug-ins can be configured to run either before or after v1 and v2 plug-ins on an individual basis, right?

This also allows multiple v1 and v2 plug-ins to be loaded now, doesn't it? It looks like there is a guarantee that among plug-ins with the same precedence of 50, we call v3 plug-ins first, then v2 plug-ins, then v1 plug-ins. Is that correct?

Is the calling order among multiple plug-ins of the same precedence and the same API version undefined?

Replying to [comment:2 nkinder]:

Looks good!

It looks like plug-ins using the v1 and v2 API's get a precedence of 50, so new v3 plug-ins can be configured to run either before or after v1 and v2 plug-ins on an individual basis, right?

Right.

This also allows multiple v1 and v2 plug-ins to be loaded now, doesn't it?

Right.

It looks like there is a guarantee that among plug-ins with the same precedence of 50, we call v3 plug-ins first, then v2 plug-ins, then v1 plug-ins. Is that correct?

Right.

Is the calling order among multiple plug-ins of the same precedence and the same API version undefined?

Right. I need to check and see if nsslapd-pluginprecedence is used for the calling order. It really depends on the order in which slapi_apib_register is called.

branch 389-ds-base-1.2.11
commit changeset:fb1e89c/389-ds-base
Author: Rich Megginson rmeggins@redhat.com
Date: Thu Aug 2 16:48:11 2012 -0600

branch master
commit changeset:e3cf726/389-ds-base
Author: Rich Megginson rmeggins@redhat.com
Date: Thu Aug 2 16:48:11 2012 -0600

Added initial screened field value.

Metadata Update from @rmeggins:
- Issue assigned to rmeggins
- Issue set to the milestone: 1.2.11.8

3 years ago

Login to comment on this ticket.

Metadata