d8b7a3c Ticket 47878 - Remove warning suppression in 1.3.4

Authored and Committed by mreynolds 4 years ago
    Ticket 47878 - Remove warning suppression in 1.3.4
    
    Description:  Perl 5.16 does not support the warning suppression of
                  "smartmatch", but 5.18 does.  RHEL 7 is currently only
                  using 5.16, so it needs to be removed from 1.3.4 for now.
    
    https://fedorahosted.org/389/ticket/47878
    
    Reviewed by: nhosoi(Thanks!)